Disabled Peripherals?

Discussion in 'General Hardware' started by Tosicc, Oct 21, 2008.

  1. Tosicc

    Tosicc Limp Gawd

    Messages:
    265
    Joined:
    Feb 19, 2008
    So today I broke open the case and took everything out including the mobo to install a PCI card and a new fan... When I booted up my 2 of 3 USB peripherals were not working... The only thing I can think of is a lack of power, this is what my build is like

    Antec 300
    Gigabyte P35
    E8500
    EVGA 8600GT
    4GB OCZ Reapers
    500GB 720.11 Seagate
    ARTIC COOLER Heatsink/Fan
    LG DVD Burner/Reader
    SoundBlaster XFI XtremeMusic
    4x120mm Apevia (blue leds)
    1x140mm Antec 3 Speed
    Logitech Standup Mic
    Logitech G15 Keyboard
    Logitech G5 Mouse
    also a 1TB HD connected thru eSata but it has its own power so..

    This is the power supply: http://www.newegg.com/Product/Product.aspx?Item=N82E16817371001

    I have everything working now except the G15 - when I plug these things in the USB connected sound goes off and it says 'Logitech Gaming Keyboard' connected but does not work, am I lacking PSU power and is there anyway to check?
     
  2. TGA

    TGA Gawd

    Messages:
    825
    Joined:
    Jun 26, 2004
    Well since you installed a PCI card I am thinking IRQ conflicts. Check your device manager for any flags.
     
  3. Tosicc

    Tosicc Limp Gawd

    Messages:
    265
    Joined:
    Feb 19, 2008
  4. enginurd

    enginurd [H]ard as it Gets

    Messages:
    21,823
    Joined:
    Jul 17, 2006
    So if you unplug, power on, and replug, do they work? Are you using ports directly on the rear i/o panel or ports via usb headers? what are the peripherals that are plugged in via usb?
     
  5. Tosicc

    Tosicc Limp Gawd

    Messages:
    265
    Joined:
    Feb 19, 2008
    plugged directly in back... no the g15 will not work
     
  6. jnex26

    jnex26 2[H]4U

    Messages:
    3,353
    Joined:
    Aug 7, 2001
    Have you tried plugging in the G15 to another PC ?
     
  7. Tosicc

    Tosicc Limp Gawd

    Messages:
    265
    Joined:
    Feb 19, 2008
    Yes and it runs fine.
     
  8. enginurd

    enginurd [H]ard as it Gets

    Messages:
    21,823
    Joined:
    Jul 17, 2006
    If USB is enabled in the BIOS, and its not working on all rear ports, it looks like you fried your ports somehow. If you take out the PCI card, does it work?