Dell PowerConnect 5524 connection delay

nry

Limp Gawd
Joined
Jul 10, 2008
Messages
409
I have a Dell 5524 which is all working perfectly besides when a server or workstation first connects, for example turn iMac on at the mains, power up and it won't have any network access for usually 30-60 seconds but the LED indicators are on and the iMac says connected (static IP)

This applies to any device I connect to the switch, 99% sure this isn't an issue with my DHCP server (pfSense) or other devices as if I connect a device to my HP ProCurve which has a trunk setup to the Dell, it works almost instantly.

What could cause this?

Config...

Code:
vlan database
vlan 3,5,10,20,30,40,50,60,70,80 
exit
voice vlan oui-table add 000181 Nortel__________________
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 001049 Shoretel________________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00907a Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
iscsi target port 860 address 0.0.0.0 
iscsi target port 3260 address 0.0.0.0 
iscsi target port 9876 address 0.0.0.0 
iscsi target port 20002 address 0.0.0.0 
iscsi target port 20003 address 0.0.0.0 
iscsi target port 25555 address 0.0.0.0 
username xxx password encrypted xxx privilege 15 
snmp-server community Dell_Network_Manager rw view DefaultSuper 
!
interface vlan 1
 ip address 10.0.100.17 255.255.255.0 
!
interface vlan 3
 name PXE 
!
interface vlan 5
 name Servers 
!
interface vlan 10
 name Traffic 
!
interface vlan 20
 name Management 
 ip address 10.0.20.17 255.255.255.0 
!
interface vlan 30
 name WiFi 
!
interface vlan 40
 name iSCSI 
!
interface vlan 50
 name Workstations 
!
interface vlan 60
 name VoIP 
!
interface vlan 70
 name Guest 
!
interface vlan 80
 name Testing 
!
interface gigabitethernet1/0/1
 channel-group 1 mode auto 
 switchport access vlan 5 
!
interface gigabitethernet1/0/2
 channel-group 1 mode auto 
 switchport access vlan 5 
!
interface gigabitethernet1/0/3
 switchport mode trunk 
!
interface gigabitethernet1/0/4
 switchport access vlan 20 
!
interface gigabitethernet1/0/5
 switchport mode general 
 switchport general allowed vlan add 30,70 tagged 
 switchport general allowed vlan add 20 untagged 
 switchport access vlan 20 
 switchport general pvid 20 
 switchport trunk native vlan 20 
 switchport trunk allowed vlan remove 1-9,11-69,71-4094 
!
interface gigabitethernet1/0/6
 switchport mode general 
 switchport general allowed vlan add 5,10,20,30,40,50,60,70 tagged 
 switchport general allowed vlan add 3 untagged 
 switchport access vlan 20 
 switchport trunk native vlan 20 
!
interface gigabitethernet1/0/7
 switchport mode trunk 
 switchport trunk native vlan 10 
!
interface gigabitethernet1/0/8
 switchport mode trunk 
!
interface gigabitethernet1/0/9
 switchport mode trunk 
 switchport access vlan 50 
 switchport trunk allowed vlan remove 1-9,11-19,21-69,71-4094 
!
interface gigabitethernet1/0/10
 switchport access vlan 10 
!
interface gigabitethernet1/0/11
 switchport access vlan 10 
!
interface gigabitethernet1/0/12
 switchport access vlan 10 
!
interface gigabitethernet1/0/13
 switchport access vlan 10 
!
interface gigabitethernet1/0/14
 switchport access vlan 10 
!
interface gigabitethernet1/0/15
 switchport access vlan 10 
!
interface gigabitethernet1/0/16
 switchport access vlan 10 
!
interface gigabitethernet1/0/17
 switchport access vlan 50 
 switchport trunk allowed vlan remove 1-9,11-19,21-69,71-4094 
!
interface gigabitethernet1/0/18
 switchport mode trunk 
 switchport trunk native vlan 20 
!
interface gigabitethernet1/0/19
 switchport access vlan 20 
!
interface gigabitethernet1/0/20
 switchport access vlan 20 
!
interface gigabitethernet1/0/21
 switchport access vlan 20 
!
interface gigabitethernet1/0/22
 switchport access vlan 20 
!
interface gigabitethernet1/0/23
 switchport access vlan 20 
!
interface gigabitethernet1/0/24
 switchport access vlan 20 
!
interface tengigabitethernet1/0/1
 switchport mode trunk 
 switchport trunk native vlan none 
!
interface tengigabitethernet1/0/2
 switchport mode trunk 
 switchport trunk native vlan none 
!
interface Port-channel1
 switchport access vlan 5 
!
ip route 0.0.0.0 0.0.0.0 10.0.20.1  
ip route 0.0.0.0 0.0.0.0 10.0.100.1
 
Last edited:
This has to do with spanning tree. I forget the exact options but you need to enable portfast. It disable spanning tree for that port. Typically you would only want spanning tree enabled on ports going to another switch anyway, so at home I just disable it on all ports. Spaning tree is a good thing though, but it does cause the ports to take longer to be "ready" when a device is added. Can be an issue if a server uses iSCSI or NFS at bootup.
 
Thanks!
Not read into that before so will have a read and play with some settings to see what's what
 
Try the command "spanning-tree portfast" on the offending/necessary ports.

Edit: See someone beat me while posting.
 
I've been having the same issue on mine at home. I haven't been annoyed with it enough to actually look for a fix yet lol.
 
Back
Top