COD:WAW Slow Load Times

lsweet

n00b
Joined
Apr 21, 2009
Messages
12
I did a search, and got multiple hits back, none that I could see pertaining to this question.

I upgraded from an 8800 GTS to a 4890, installed the latest available drivers for Windows 7 x64, and eventually made my way into a COD:WAW game.

Using my 8800 (Under the same OS) I could load into a fresh map and be one of the first players in while waiting for the round begin timer to finish counting down. With my 4890, I barely make it before the round begins.

I'm curious if this is a common issue for others, or if anyone is aware of this being a known issue.
 

86DRIFTER

Limp Gawd
Joined
Oct 3, 2006
Messages
351
I'm also having this problem. I have an ATi HD4830. I went to a LAN party where everyone else had an NVidia card and I was the slowest one loading.
 

risqu3

[H]ard|Gawd
Joined
Mar 4, 2008
Messages
1,267
i dont know about W@W but in COD4 i had no problems loading ANY level quickly.
 

lsweet

n00b
Joined
Apr 21, 2009
Messages
12
i dont know about W@W but in COD4 i had no problems loading ANY level quickly.

Me either. But the minute I popped in this card -- I'm suddenly the slowest to load a level... Well... one of the slowest. Once in though; there is no problems (aside from alt+tabbing out, but that's another issue for Google to help with when I'm not lazy)
 
D

Deleted member 174368

Guest
I used to have this problem in single-player only... took up to 3 minutes to load a level (compared to ~5-7 seconds in CoD4). Later on when I reinstalled the OS it went away though, so not sure what exactly went wrong.
 

F.E.A.R.

[H]ard|Gawd
Joined
Sep 30, 2005
Messages
1,456
I have the same problem too. In COD4 I would be one of the first ones in a map , but with W@W I am one of the last ones. I believe, it's the way the card handles the heavy textures of the game. COD4 has less environment textures.
 

sirmonkey1985

[H]ard|DCer of the Month - July 2010
Joined
Sep 13, 2008
Messages
22,230
cough cough.. another reason cod:WaW sucks... lol.. though i dont see how running a different gfx card nvidia or ati could effect the load times of a game.. maybe you should take a look at your entire rigs setup..
 

lsweet

n00b
Joined
Apr 21, 2009
Messages
12
cough cough.. another reason cod:WaW sucks... lol.. though i dont see how running a different gfx card nvidia or ati could effect the load times of a game.. maybe you should take a look at your entire rigs setup..

Well, let me if I can be specific as to what happen.

I was playing WAW after coming home from work (I work nights). My doorbell rang and it was a friendly Purolator guy delivering me a package containing a video card. I ran gleefully to my computer and ripped open the box and grew excited at the contents.

From there came a series of very magical, mysterious steps in which I followed...

I uninstalled the 8800's graphic drivers and ran driver sweeper to remove JUST the nvidia drivers.

I swapped the physical cards from the 8800 to the 4890.

Installed the latest 9.4 (and now the 9.5) Catalyst drivers

Game loaded slower, but prettier and with higher FPS...

So..umm... I'm still leaning towards my rig and setup are fine and falling back on the popular 'Treyarch sucks'
 

Astrodave

[H]ard|Gawd
Joined
Apr 20, 2005
Messages
1,082
Just replaced 4850CF with a GTX285. I always wondered why cod5 loaded so much slower than everyone else and never put it together that it was my ati card causing it until I put in the nvidia card last week and the game loaded about 5x faster. The IQ is also 5x better with the nvidia card and the game runs twice as smooth. Something with the ati cards does not agree with cod5. I never noticed any other load time slowdowns in any other games but honestly I really only ever play cod5 and fsx with any regularity.
 

Tudz

Supreme [H]ardness
Joined
Jun 15, 2008
Messages
7,434
I've had no end of trouble with COD:WAW on my computer which runs a 4870, but it runs fine on my computer which runs an 8800GTS 320mb. Well, maybe "fine" is an exaggeration, can't alt tab out without it throwing a hissy fit and if my TV tuner card software runs into a bump while running in the background, WAW just freezes (where as COD4 would run fine with the same software running in the background).
 

Beakerz

n00b
Joined
May 15, 2008
Messages
63
I was playing retail version of CODWAW on my system and load times were fine with my 4870x2, but then we updated our games to 1.4 and now my load times are terrible, performance is game is just fine, but loading the game is slow at start up as well as new maps and such :(
 

MrkXCeL

[H]ard|Gawd
Joined
Jun 11, 2004
Messages
1,206
COD5-W@W slow as molasses, performance fine, COD4 fast load, peformance also fine.
Running a 3870 with 1.4s with CODW@W - Steam version of the game, thought this might have been my problem.

Wonder if there's something goin with ATI cards downclocking between level loads? Could this affect it that much? Does ATI even do this on the memory side, or is it just the chip gets clocked down in 2D mode?
 

Mamba

n00b
Joined
May 28, 2009
Messages
1
Spyre is a good dude. I'm sure they'll get this taken care of.
Hmm...I wasn't thrilled that he locked the thread in question and he was very terse when I PM'd him regarding this about a month ago. The only semi-helpful info I got via PM with him was to "watch the release notes" for new drivers. Not exactly inSpyreing (pun intended) information, and so far seen nada for COD5 in said notes.

For the record, two of our clan run ATI 3000 series AGPs (3850, 3650) and have the delay problem...90+ seconds on map load. Been scouring the 'net for any solutions and so far the discussed ATI lead is all I've found so hoping they do release a fix soon, but not optimistic thus far.
 
Top