Can't connect to Server 2008 via Server Manager on Windows 7?

AMD_Gamer

[H]ard as it Gets
Joined
Jan 20, 2002
Messages
18,283
I have install the administration toolpack on Windows 7 and enabled remote connections on my server 2008 box, When i try and connect with my Windows 7 server manager it does not work.

I see stuff on google about enabling a trustedhost with winrm but can't find a way to do this.

this seem more difficult than it should be?

this is what I keep getting

 
Last edited:

xenios

Gawd
Joined
Aug 8, 2008
Messages
992
edit, I was wrong. https requires a non self signed cert


do the following in powershell, this is for powershell remoteing but it does the winrm stuff as well:

on the server:
Code:
Enable-PSRemoting –force
on the client:
Code:
Start-Service WinRM
Set-ItemProperty –Path HKLM:\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System –Name  LocalAccountTokenFilterPolicy –Value 1 –Type DWord
Set-Item WSMan:\localhost\Client\TrustedHosts &#8211;Value <ServerName> -Force -Concatenate
Be warned that this is very insecure.
 
Last edited:

xenios

Gawd
Joined
Aug 8, 2008
Messages
992
I just edited my post, after some reading I saw the cert requirement. And since you can not use self-signed certs thats out of the picture too.
 

AMD_Gamer

[H]ard as it Gets
Joined
Jan 20, 2002
Messages
18,283
edit, I was wrong. https requires a non self signed cert


do the following in powershell, this is for powershell remoteing but it does the winrm stuff as well:

on the server:
Code:
Enable-PSRemoting –force
on the client:
Code:
Start-Service WinRM
Set-ItemProperty –Path HKLM:\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System –Name  LocalAccountTokenFilterPolicy –Value 1 –Type DWord
Set-Item WSMan:\localhost\Client\TrustedHosts –Value <ServerName> -Force -Concatenate
Be warned that this is very insecure.
Enable-PSRemoting –force is not recognized


why is this so hard? is this just because I am in a workgroup situation? i would figure using the remote admin tools should be very easy.
 

xenios

Gawd
Joined
Aug 8, 2008
Messages
992
Oh you said 2008 not 2008 r2, meaning you are probably not using powershell v2 on the server.

on the server try:
Code:
winrm quickconfig
on the client keep those commands the same

And yes this is because you are in a workgroup. Out of the box this sort of remoting is not supported in a workgroup as you dont have a central authentication model.
 

AMD_Gamer

[H]ard as it Gets
Joined
Jan 20, 2002
Messages
18,283
Oh you said 2008 not 2008 r2, meaning you are probably not using powershell v2 on the server.

on the server try
Code:
winrm quickconfig
i did that earlier, with no luck, should i still do those other commands on the client?

there must be a more simple way to do this
 

xenios

Gawd
Joined
Aug 8, 2008
Messages
992
Those commands should work. You need to run powershell as an elevated process. if they dont work after that paste the output.
 

AMD_Gamer

[H]ard as it Gets
Joined
Jan 20, 2002
Messages
18,283
this is what i followed before with no luck,

If you are managing a remote computer from a computer that is running Windows 7, start the Windows Remote Management (WinRM) service to allow for the addition of trusted hosts. Open a Command Prompt session with elevated user rights by clicking Start, clicking All Programs, clicking Accessories, right-clicking Command Prompt, and then clicking Run as administrator. Type the following, and then press Enter: net start winrm

For remote connections in a Workgroup to Workgroup/Domain scenario, the remote computer must be added to the trusted hosts list on the source computer. To do this, run the following command on the source computer in a Command Prompt window that is opened with elevated user rights.

winrm set winrm/config/client @{TrustedHosts="RemoteComputerName"}

For remote connections in a Workgroup to Workgroup/Domain scenario, if a user is not logged on by using the source computer’s built-in administrator account, the following WinRM registry key must be configured to allow remote access from the source computer. This change is required because of a User Account Control (UAC) limitation on non-administrator accounts that are members of the Administrators group. To change this registry key, run the following command on the source computer at a command prompt that is opened with elevated user rights.

reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /v LocalAccountTokenFilterPolicy /t REG_DWORD /d 1 /f

By default, WinRM allows for a maximum of five connections to a remote computer to be active per user. To increase the limit, run the following command on the source computer, in which X represents the number of connections that you want to allow, at a command prompt that is opened with elevated user rights.

winrm s winrm/config/winrs @{MaxShellsPerUser="X"}
 

AMD_Gamer

[H]ard as it Gets
Joined
Jan 20, 2002
Messages
18,283
ok i did it in powershell and now the second command says that the < operator is reserved for future use at line 1 char 55
 

xenios

Gawd
Joined
Aug 8, 2008
Messages
992
sorry, dont include the <>. also how are you connecting to the server by ip, or name.
 

xenios

Gawd
Joined
Aug 8, 2008
Messages
992
You have me curious enough to actually try this at home where a workgroup actually exists. Ill report back later.
 

AMD_Gamer

[H]ard as it Gets
Joined
Jan 20, 2002
Messages
18,283
You have me curious enough to actually try this at home where a workgroup actually exists. Ill report back later.
wow thanks a lot man. I guess i am stuck with remote desktop for now.

I was planning on installing the standalone Hyper-V server tonight, will I have this same problem connecting to it with the remote admin tools? How will i be able to admin that?
 

xenios

Gawd
Joined
Aug 8, 2008
Messages
992
Ok, I got it all working. I spent alot of time trying to do it via self signed ssl certs and thats is not going to work. Non self signed certs do work but you probably do not have the means to make one. So here is what worked for me on unsecured http.

Make sure both computers have a common username / password

on your machine:
Code:
winrm set winrm/config/client @{TrustedHosts="ip of the server"}
on the server
Code:
winrm quickconfig
Thats all i did and it worked (basically what both of us posted before). you need to make sure if you use the ip to connect you use the ip for trustedhosts.
 

AMD_Gamer

[H]ard as it Gets
Joined
Jan 20, 2002
Messages
18,283
Ok, I got it all working. I spent alot of time trying to do it via self signed ssl certs and thats is not going to work. Non self signed certs do work but you probably do not have the means to make one. So here is what worked for me on unsecured http.

Make sure both computers have a common username / password

on your machine:
Code:
winrm set winrm/config/client @{TrustedHosts="ip of the server"}
on the server
Code:
winrm quickconfig
Thats all i did and it worked (basically what both of us posted before). you need to make sure if you use the ip to connect you use the ip for trustedhosts.
i did that stuff before:confused:


anyways I am installing hyper v server now, hopefully I don't have the same problem.
 
Top