Cannot get new GPU core 15 to install


[H]ard|DCer of the Month - March 2009
Sep 17, 2000
I noticed there has been some talk about a new GPU core for beta WUs or somesuch, and my clients attempted a force installation of the new core tonight without success. I'm still using the console client and I get the endless repeated cycle of downloaded new core, error, redownload, etc., then the inevitable 24hr pause. Here's one example:

[02:43:59] Trying to unzip core FahCore_15.exe
[02:43:59] - Couldn't open file FahCore_15.exe
[02:43:59] + Error: Could not extract core
[02:43:59] + Core download error (#2), waiting before retry...

Another example:

[23:09:58] Window's signal control handler registered.
[23:09:58] Preparing to commence simulation
[23:09:58] - Assembly optimizations manually forced on.
[23:09:58] - Not checking prior termination.
[23:09:58] sizeof(CORE_PACKET_HDR) = 512 file=<>
[23:09:58] Need version 225
[23:09:58] Error: Work unit read from disk is invalid
[23:09:58] Folding@home Core Shutdown: CORE_OUTDATED
[23:10:02] CoreStatus = 6E (110)
[23:10:02] + Core out of date. Auto updating...
[23:10:02] New core downloaded for this work unit, but still out of date.
Folding@Home will go to sleep for 1 day as there have been 5 consecutive Cores executed which failed to complete a work unit.
[23:10:02] (To wake it up early, quit the application and restart it.)
[23:10:02] If problems persist, please visit our website at for help.
[23:10:02] + Sleeping...

Apologies if the subject matter has already been duplicated elsewhere in this forum. I searched to see if anyone else has had the same or similar situation to no avail. I could only find info pertaining to the QRB WUs that don't apply in my situation because I'm not running Fermi. Thanks for any help on this issue. I have 10 GPU clients that have been idle for several hours...
FahCore15 is only supposed to be for Fermi or newer if I recall correctly. Sounds like Stanford servers giving out incorrect WU/Cores to the wrong hardware. Try removing the work folder and the cores and start the client again. See if it picks up a WU/core combo it can actually process.
And what version of the console client are you running?
Thanks for the quick replies. I have been assigned FahCore_15 WUs on these clients up to version 2.22 for quite a long while. The new core seems to have many changes included likely because of the QRB units. I don't know if this is somehow affecting my clients.

My GPUs are a mix bag of G80 and GT200 cards. The client version is 6.41r2 from what I see in the logs. I don't know if that is the most recent version up to the official release of the GUI-based v7 client. I looked at Stanford's site and there appears to be an older version 6.23 which I tried but it didn't make a difference. I still receive errors.
IDK if this is relevant to OP, but to further add on to this. I've been running the GPU2 tray version for the past 3 years with no problems and today randomly it crashes with the:

fahcore_15.exe crashed: cannot find cudart32_30_14.dll

It's a GTX260 and uninstall/reinstall produces the same error as well as uninstalling/reinstalling Nvidia's Phyx drivers. All other version install just fine but they don't run on the GTX260. The GPU3 goes at 1ns vs 400ns+ on this now defunct GPU2 client and using 6.2.9 - 7.2.9 versions it just halts at 0.0%

Is this in relation to OP or something else? I really don't understand how the whole F@H works, but I find it odd it just crashes like that and none of the other clients work well with the GTX260.

I forgot about my 11th GPU client I have running, which happens to be a low-end 400-series Fermi card. This client already had the v2.25 FahCore_15.exe file, so I transplanted it into all my other clients, and it works. Now I'm wondering if I did the right thing because my G80-flagged clients are receiving the same WUs as my Fermi client...! :eek:

Is this correct and permissible? According to the errors I was seeing earlier, it was stated I required core 15 v2.25, and now that I'm running that exact core I'm downloading what appear to be Fermi WUs, unless something has changed and every nVidia card generation is folding the same WUs according to the new WU scheme...?? :confused:
Had this same problem with a GTX260 and now a GTX460. Both hung on Updating core and needed a manual replacement from another machine as they just kept on downloading 2.22
Had this same problem with a GTX260 and now a GTX460. Both hung on Updating core and needed a manual replacement from another machine as they just kept on downloading 2.22
I vaguely remember this happened to me a couple of years back when there was another core update. I guess this is unrelated to the current update and possibly a configuration problem somewhere. It's weird that 5 systems would get stuck like that. I don't know what I would have done if I didn't happen to have a Fermi client with the current core to copy over to the rest of the farm.

Anyway, I'm leaving things the way they are now and see what transpires. Temps are up on the new core and 7000-series WUs, which should be good until spring. Later on will be a problem.
Judging by the threads over at FF, there are lots of problems at the moment, they even have ATI cards trying to download core15, current recommendation is to pause the client until it is fixed.
Apparently, an update by Vijay earlier today says that PG has made some fixes to the assignment server so problems with the wrong cores being assigned to the wrong machines should supposedly start to clear up... I haven't had the problem since, but I'm still keeping an eye on things to be sure.