Bummed. DOA PSU.

Phandalyon

Guest
Joined
Jun 12, 2001
Messages
5,840
Just got my OCZ Powerstream 520W PSU. I was really excited to get everything hooked up and running, so tonight I sat down and took out my crappy old Allied 450W and reconnected the OCZ.

I went an plugged everything back in to my computer...

Bright Flash.

No Power.

I pulled it out and hooked it up to my little PSU tester and it was dead. So I hooked my old Allied back up and sent an email off to OCZ to see if I can get an RMA.

What a bummer. I was really excited about having full functionality on my computer (I have been having power issues).

Oh well. Now I have to wait a little longer.
 

OldMX

2[H]4U
Joined
Mar 17, 2002
Messages
3,532
Just rma it and get a new one, no big deal..

you're not the first or the last one getting doa hardware :)
 

Phandalyon

Guest
Joined
Jun 12, 2001
Messages
5,840
The email is already sent. I am going to call Monday too. And now that I have vented my disappointment all I can do is wait.
 

OldMX

2[H]4U
Joined
Mar 17, 2002
Messages
3,532
I feel your pain, i've been in the same boat a couple of times :(

Good luck with that rma :p

0ldmX
 

Phandalyon

Guest
Joined
Jun 12, 2001
Messages
5,840
A little update on OCZ zupport if anyone is interested.

After emailing them on Saturday I called them on Monday.

No one answered and I left a message for the support team.

Today (Wednesday) came around with no response on the email (Not even an auto response) and no return phone call. I was getting pretty upset with them.

There is no RMA request on their website. I tried calling them again several times this morning and got a busy signal every time, so I finally got onto their official support forums. About 10 minutes after registering and posting on the forum I got a response from them.

After having me double check a couple of things (trying to jump start the PSU) they sent me the RMA materials and I got my RMA number. They are supposed to have a cross-ship warranty, but it only works if you send them the tracking number from the carrier you shipped with. So I just boxed the PSU up and shipped it UPS back to them. Their bad unit cost me an extra $9.00 in shipping, so I am a little upset about that after already paying $140 plus shipping (IIRC) once.

Anyway, I just sent them an email with the tracking number, we will see if they actually cross-ship the PSU or not. I am honestly starting to get a little but worried as so far my experience has not been good.

Kudos to the Forum support though, if you need support from OCZ go through the forums. Calling or emailing them is completely worthless and a waste of time.
 

Phandalyon

Guest
Joined
Jun 12, 2001
Messages
5,840
Update (If anyone cares): Just got an email saying they will ship the new PSU out tomorrow.
 

Borgschulze

2[H]4U
Joined
Feb 28, 2005
Messages
3,579
Phandalyon said:
Update (If anyone cares): Just got an email saying they will ship the new PSU out tomorrow.
I just bought one of these, shipped today.
Can't wait to get it :cool:
I should have mine tomorrow or Friday.
 

Phandalyon

Guest
Joined
Jun 12, 2001
Messages
5,840
Borgschulze said:
I just bought one of these, shipped today.
Can't wait to get it :cool:
I should have mine tomorrow or Friday.

I am starting to get excited to get mine again. I really want my computer to function properly again.
 

knothead34

[H]ard|Gawd
Joined
Apr 4, 2005
Messages
1,599
im sorry to hear about your bad experience. there are a couple of ocz guys who actually frequent dfi-street.com. i just wanted to give you a heads up if you have a issue with an ocz product power supply or ram ocz andy is his name goes to dfi-street. can send him a private message and i believe he will take care of you.
 

Phandalyon

Guest
Joined
Jun 12, 2001
Messages
5,840
knothead34 said:
im sorry to hear about your bad experience. there are a couple of ocz guys who actually frequent dfi-street.com. i just wanted to give you a heads up if you have a issue with an ocz product power supply or ram ocz andy is his name goes to dfi-street. can send him a private message and i believe he will take care of you.

Thanks for the info. Once I got into the official support forum for OCZ I had no problems at all. I guess the moral of the story is that if you have issues with your OCZ equipment, don't bother with calling or emailing support, go straight to the forums. I will be heeding this lesson in my future dealings with them.
 

Phandalyon

Guest
Joined
Jun 12, 2001
Messages
5,840
Just another update. I got the Tracking number yesterday (Friday) for the new PSU.

Overall I would give OCZ support a C. THey were great to work with and very prompt once I was able to get ahold of them. It was the getting ahold of them that sucked.

Well. Just a little info.
 

Phandalyon

Guest
Joined
Jun 12, 2001
Messages
5,840
Final Update:

Sorry to keep bumping this.

I recieved the new PSU this morning (Monday). This afternoon I had an opportunity to sit down and install it in my ne Lian Li case. Everything fired right up and I could not be happier. All of my USB devices and drives are once again functional.

So aside from my little glithes listed above, I would highly reccomend this PSU to anyone who is in the market for more juice. Thanks for letting me rant and hopefully this thread helps someone else in the future.
 
Top