Bogus Vmware guest memory usage warning

danswartz

2[H]4U
Joined
Feb 25, 2011
Messages
3,647
So I have a VEEAM backup proxy configured with a mellanox 50gb SR-IOV adapter to talk to storage. Being SR-IOV, it requires the guest to have all memory reserved. VCSA is constantly flagging an alert for this guest due to 'memory usage'. This is not an issue with the guest, it's a vmware requirement! Why is it doing this? A bug? ESXi 6.5. I don't want to disable that warning altogether :(
 

Eickst

[H]ard|Gawd
Joined
Aug 24, 2005
Messages
1,866
You can disable all alarm actions for that VM if you want, just right click on the VM, alarm, disable alarm actions

If you don't want to do that...then you have to disable that alarm at the vcenter level, and add it back in at lower levels like a folder, just put that VM in a folder that you don't add that alarm to.
 

danswartz

2[H]4U
Joined
Feb 25, 2011
Messages
3,647
I think option #1 is the way to go. This seems like a bug, but not a serious one... Thanks!
 

Spartacus09

[H]ard|Gawd
Joined
Apr 21, 2018
Messages
1,247
What revision of 6.5 are you on? are there any patches/updates that might resolve that?
I second the alarm silencing/threshold editing otherwise.
 

Spartacus09

[H]ard|Gawd
Joined
Apr 21, 2018
Messages
1,247
There is one more patch newer 10719125, but it came out 2 days ago, :p not likely the issue then.
 

danswartz

2[H]4U
Joined
Feb 25, 2011
Messages
3,647
I checked that one - it seems to be a vmxnet3 exploit that was fixed. I upgraded anyway :)
 

danswartz

2[H]4U
Joined
Feb 25, 2011
Messages
3,647
Odd. Disabling alarm actions didn't work. I logged back in to vcsa html5 gui and see the same vm memory usage alert. Definitely a bug here. Oh well...
 

danswartz

2[H]4U
Joined
Feb 25, 2011
Messages
3,647
Yeah, that sure looks like it. Passing in an SR-IOV NIC, requiring locking all memory. It's funny how the phrasing of the KB makes it sound like it isn't a bug :)
 

Eickst

[H]ard|Gawd
Joined
Aug 24, 2005
Messages
1,866
It's from the vmware KB -

This is a display artifact only and has no negative performance impact on the virtual machine or the host it is running on.

To work around this issue, disable the Virtual machine memory usage alarm to avoid false positives.
 

ironforge

[H]ard|Gawd
Joined
Feb 7, 2006
Messages
1,235
So I have a VEEAM backup proxy configured with a mellanox 50gb SR-IOV adapter to talk to storage. Being SR-IOV, it requires the guest to have all memory reserved. VCSA is constantly flagging an alert for this guest due to 'memory usage'. This is not an issue with the guest, it's a vmware requirement! Why is it doing this? A bug? ESXi 6.5. I don't want to disable that warning altogether :(
During one of the VMworld 2018 presentations, one of the vmware employee's said using the memory alert is mostly a waste of time. When you do a memory reservation, vcenter will always see all of the memory "in use" because it is "reserved". NO way around that. Free annoying alerts! Yay! VMware employee recommended to disable memory alerts.
 
Top