Blu Tooth Issue After installing 1803

Discussion in 'Operating Systems' started by TechLarry, May 12, 2018.

  1. TechLarry

    TechLarry Pick your own.....you deserve it.

    Messages:
    28,463
    Joined:
    Aug 9, 2005
    Anyone else seeing Dev Manager issues with their BluTooth hardware after installing Win10 1803 ?

    In my case, it's the Asus BTC400 USB Adapter, and this is the device striing:

    upload_2018-5-12_9-43-18.png


    I have not been able to find a driver anywhere to fix it. I tried Windows update, the ASUS driver and even the generic Intel driver. No joy.

    The funny thing is, my BT mouse still works. I'm just afraid this is a land mine waiting to be stepped on.

    Lots of reports on the net but no solutions I could find.

    TLDR:
    Windows 10 1803 done fucked up Blutooth.
     
  2. heatlesssun

    heatlesssun Pick your own.....you deserve it.

    Messages:
    48,277
    Joined:
    Nov 5, 2005
  3. TechLarry

    TechLarry Pick your own.....you deserve it.

    Messages:
    28,463
    Joined:
    Aug 9, 2005
    Yes, but it doesn't solve the problem. It's an OLD driver.
     
  4. pendragon1

    pendragon1 [H]ardForum Junkie

    Messages:
    9,478
    Joined:
    Oct 7, 2000
    if its working just wait for them to update the driver. or bug intel for an update.
     
  5. David Luiz

    David Luiz n00bie

    Messages:
    2
    Joined:
    Jun 13, 2018
    Facing same kind of issue
     
  6. bigdogchris

    bigdogchris Wii was a Novelty

    Messages:
    17,342
    Joined:
    Feb 19, 2008
    I've seen a lot of BT drivers that are only available through Windows Update for some reason. I think the companies are working specifically with Microsoft to keep the hardware working.

    What you could do is install the adapter on a 1709 machine and back up the driver, then try bringing the driver over to 1803 and keeping a backup.