Asus K8V Deluxe problems after flashing bios


Limp Gawd
Jun 8, 2004
Ok, so i tried flashing my bios, and it failed after erasing my current bios. now all i get is system failed cpu test. i've tried everything i know to do, and also tried everything the asus techies told me to try. nothing has worked.
So i guess my question is, is it fixable or am i basically stuck getting a new mobo.

and second how fast or slow is asus' RMA turn around?

Just a FYI, It was working for several days fine with no problems at all untill i tried flashing it.

Things I've tried:
clear cmos
leave it unplugged with no battery
reseat cpu
double check all fan connections
double check for no bent pins on cpu
hook up only the video card cpu and see if it'd let me into the "non existant bios"
I've had this happen to me before and I ended up replacing the BIOS chip itself. It looks like your BIOS chip can be replaced from pictures I've seen of that mobo. You've tried everything else I can think of so a replacement might be your last resort. I was very impressed with when I needed a new BIOS chip. They will flash whatever BIOS (newest) you want onto the new chip.
Thanks for the link, I just ordered what i needed for 25 bux plus 14 next day shipping.

In order for Asus to crossship they wanted 180 security deposit...then wanted me to fill out tons of paperwork and fax it to them. then i'd have to go back to the post office and send them i figured to save a lot of time and hassle i'd just order the chip...see if it works if not i'll use asus' rma. if that doesn't work i'll just be out of luck..and order a new mobo. not a big deal only 120 bux.
The instructions they include are pretty good, but if you have any questions I'll be glad to help. Just make sure you pull the old one straight up and push the new one straight down. There are alot of pins and it only takes one bent one to mess it all up. :(