Areca 1880-16ix - 1 Reading error, should I change hdd ?

chcoust

n00b
Joined
Aug 1, 2009
Messages
2
Hello all,

I'm an happy owner of the Areca 1880-16ix controller for about 1 year and a half now, and I recently faced my first hard drive failure.

My configuration is RAID6, 9x2 TB, 14 TB volume, and no hot spare before this month
Firmware Version V1.49 2010-12-10
BOOT ROM Version V1.49 2010-12-10
PL Firmware Version 7.0.0.0
1 GB memory, no battery


I have had 2 main problems:
- the controller did not send me any of the error events by mail, even if it was configured to "Warning Error Notification / Send Urgent, Serious And Warning Event" and that I normally received my “Http Login” mails. I changed it to "Information Notification / Send All Event". And so the volume went for like 15 days in degraded mode.
- 2nd problem : hdd prices made a 3x bump so I took 2 spares drives we had at work, and one of them (the first one I tried) died on me during volume rebuild

Finally, I managed to rebuild my raid with one hdd from work, sent my failed hdd to WD, and received a refurbished one, which I have in hot spare for now. I had some problems that I managed to resolve when I was rebuilding everything (both my volumes went down / many drives shutdown / in error) but all went back and correctly working after a reboot without the rescue commands. (I read many thread from this forum and some of you faced those kinds of errors before)
I have also read that it’s good to schedule a monthly volume checking, and I will setup that soon.

BUT ! the reason of that post is that I have one last drive with 1 error when I check my volume. I checked it twice with scrubbing bad blocks option on, and that drive always gets the error. Do you think scrubbing can get me rid of that error? Notice that the volume doesn’t get degraded after checking. Do you think that I need to change the hdd in SLOT3 ?

Thanks for your honest answers !


Here is the cleaned log of my recent problems
areca_log.png
 

mwroobel

Supreme [H]ardness
Joined
Jul 24, 2008
Messages
5,039
I would change the drive immediately. I just had a 3TB hitachi go last night in a 12 drive raid 6 on my 1880i. It started a 7 reading errors in a time period of about 15 minutes, and then the drive failed. I restarted and tried adding the drive back as a spare and the drive again (and rebuild) failed in about 10 minutes, also preceded by the Read Errors. I put a new drive in and the rebuild is just about done tonight.
 
Top