Android 3.1 Wifi issue.

C7J0yc3

[H]ard|Gawd
Joined
Dec 27, 2009
Messages
1,353
Hey all, got a strange wifi issue that I can't seem to figure out. Before upgrading my A500 to 3.1 everything was great. After upgrading to 3.1 any network I connect to with security on it will not hand a DHCP address to my tablet. It just goes through the connecting, acquiring IP, disconnected/remembered cycle about 4 times then stops trying. If I manually assign an address to it everything works just fine. If I delete the network and re-add it, I have the same problem. Any open network connects without issue.

Any ideas on how to resolve this issue?
 

notarat

2[H]4U
Joined
Mar 28, 2010
Messages
2,415
Are you entering the passphrase or key when trying to join the secured network? (just asking because you didn't mention doing that part. I have to enter the passphrase in order to join my protected Wi-Fi network)
 

C7J0yc3

[H]ard|Gawd
Joined
Dec 27, 2009
Messages
1,353
If I delete and rejoin the network, then yes I have to put in the WPA2 key, however the device still doesn't join the network. If I try to join the same network from any other device there isn't a problem.
 

AQ_OC

2[H]4U
Joined
Jan 23, 2011
Messages
2,131
Are you using the real 3.1 that starting going out yesterday, or the fake one?
 

C7J0yc3

[H]ard|Gawd
Joined
Dec 27, 2009
Messages
1,353
img0211tb.jpg


That is the version I am running. I didn't use the modified update.zip for root, and have not rooted the device.
 

AQ_OC

2[H]4U
Joined
Jan 23, 2011
Messages
2,131
Most think that is an early beta of 3.1. I got the official update to 3.1 on July 4. I wonder if the early beta is your problem.

IMG_0130.jpg
 

C7J0yc3

[H]ard|Gawd
Joined
Dec 27, 2009
Messages
1,353
Most think that is an early beta of 3.1. I got the official update to 3.1 on July 4. I wonder if the early beta is your problem.

Seems I am not alone, and looks like the issue was fixed in the main release. The fix is to delete the file /data/misc/dhcp/dhcpcd-wlan0.lease and then reconnect the tablet to the network. This fixed the problem instantly.
 

rsharma

n00b
Joined
Jul 7, 2011
Messages
2
Hi I have the same problem, Can you advise how to I delete the file you mentioned above. I am not very familiar with Android OS and how to make tweaks.
 

C7J0yc3

[H]ard|Gawd
Joined
Dec 27, 2009
Messages
1,353
Firstly you need to have root access on the device.

Next you can delete the file one of two ways

1: Through a file manager like root file manager
2: Through a terminal

I did it through a terminal using the following commands

su
cd /data/misc/dhcp
rm dhcpcd-wlan0.lease

after that everything was fine, and no reboot needed.
 

rsharma

n00b
Joined
Jul 7, 2011
Messages
2
Hi after breaking my head over how to root. I just did a factory reset and incidentally the factory reset loaded 3.1 directly and the problem of connecting with wi fi was also resolved.

Thanks for everyone's help. My ACER A500 does not allow me to download any root file manager. It says that it is incompatible with my device. Any suggestions for this problem for the future
 
Top