AMD 280X black screen issue

buttons

2[H]4U
Joined
Oct 12, 2011
Messages
2,068
You guys are a lot smarter then me so i thought maybe id see if you guys have any thoughts. I decided to upgrade my W7000 to a XFX 280X. During boot up it kept black screening on me, i thought i had it solved when i learned the HDMI 1.4a port does not support 1440p at 144hz. However, today its doing it again. Event logs show:

Faulting application name: Radeonsoftware.exe, version: 10.1.2.1862, time stamp: 0x6075cb03
Faulting module name: Radeonsoftware.exe, version: 10.1.2.1862, time stamp: 0x6075cb03
Exception code: 0xc0000005
Fault offset: 0x00000000003d7c92
Faulting process id: 0x2ee0
Faulting application start time: 0x01d740fb2ba90b45
Faulting application path: C:\Program Files\AMD\CNext\CNext\Radeonsoftware.exe
Faulting module path: C:\Program Files\AMD\CNext\CNext\Radeonsoftware.exe
Report Id: 6579152c-e00c-4def-94c8-5d8bd01eddf1
Faulting package full name:
Faulting package-relative application ID:

When i installed the card I ran the AMD clean up utility then installed the latest driver for a 280x. Card runs 75c under load, i was quite disappointed with its performance. More or less seems the same as the W7000 on overwatch but it looks a lot better in the case. I ordered a mini display port to display port cable -- hopefully its just an issue with its HDMI port. When i get back home from lunch i am going to put it in my spare rig and see if problem continues there.

Edit: had it running in the spare machines a few hours now on HDMI 1920x1080@120hz. No issues at all, so it must be some software conflict or it doesnt like my HDMI 2.1 cable / 2560x1440 144hz monitor.
 
Last edited:

pendragon1

Fully [H]
Joined
Oct 7, 2000
Messages
27,199
theyre basically the same, it was not much an upgrade, just a revision. 75c is fine. they will not do high res/refresh, they are a 1080p/60 card, and even then TPU has a warning on it.
1620170387623.png
 

TordanGow

[H]ard|Gawd
Joined
May 25, 2015
Messages
1,478
Have you tried updating your motherboard bios? I had issue with a 280X a ways back, updating the motherboard bios fixed it.
 

buttons

2[H]4U
Joined
Oct 12, 2011
Messages
2,068
theyre basically the same, it was not much an upgrade, just a revision. 75c is fine. they will not do high res/refresh, they are a 1080p/60 card, and even then TPU has a warning on it.
View attachment 353286
The specs are very different, but you are right about the 1080p/60 part. W7000 has 1280 stream processors, lower clocks on core and memory. 256bit memory instead of 384bit. Since i only use 144hz monitors it only allowed me to change settings from medium to high on overwatch. Going to ultra / epic fps drops below 60 from 120. Sad my laptop with 2060 does 130ish on ultra 2560x1440.
 

pendragon1

Fully [H]
Joined
Oct 7, 2000
Messages
27,199
The specs are very different, but you are right about the 1080p/60 part. W7000 has 1280 stream processors, lower clocks on core and memory. 256bit memory instead of 384bit. Since i only use 144hz monitors it only allowed me to change settings from medium to high on overwatch. Going to ultra / epic fps drops below 60 from 120. Sad my laptop with 2060 does 130ish on ultra 2560x1440.
whoops, missed the "performance" after the "same. yeah that 2060 is a waaaaaay better card than either of the others, totally different class.
 
Top