Alienware Area-51m 7700 LCD Issue, please help

Joined
Jan 17, 2007
Messages
624
Hey,

I'm getting a single red line vertically down the right side of my lcd. A blue one is starting to form a little to the left of the first one. I am unsure of whether or not the problem lies with the lcd cable or the lcd itself. Tested it with an external monitor, so it is not the graphics card. Any ideas? It's kind of weird cause the line disappears on blacks and whites... It only shows up on colors mostly.
 

K-TRON

Limp Gawd
Joined
Oct 29, 2008
Messages
336
The problem is related to the Video connector.
I have had this happen to me on my Voodoo envy, which is also a D900K
Remove the keyboard.
Use a flathead screwdriver to depress the 4 clips which hold it down.
Underneath the keyboard is a metal plate which is held down by 5 screws
remove theses screws.
Once removed, remove the plastic black bezel which is between the keyboard and the screen.

On the left most side there are three connectors which run up to the sceen. The 4 pin USB cable for the webcam, the 7 or so pin connector for the inverter, and the 25 pin or so port for the LCD

You want to focus on the larger of the connectors.
Use the blunt end of a pencap to push each wire down into the plastic boot.
Make sure each is connected properly.
When all are connected. fit some tape over the connector so that when the plastic piece is installed, it keeps the wires in place.
You can do this when the laptop is on, thus you can find out exactly which wire is loose causing the problem.

If this does not help, your next bet is to dissassemble the lid. There are 8 screws which hold the two halves of the lid together. Once removed you need to get to the back of the LCD.

There is a cable which plugs into the back of the LCD. You want to remove it and reconnect it.
Once connected, use a few pieces of electrical tape to hold the ribbon cable in place.

Your problems should be completely fixed after doing both operations.

K-TRON
 
Top