"Zero Display Serivce Error" + 9600po = no 3D?


Dec 25, 2004
I've just swapped out a 9600 pro for a 9800 pro, and the things being a pain about installing. Every time I try it install the drivers I get a "Zero Display Service Error". After installing it it draws 2D thing painfully slowly and I get memory allocation errors when using DX and OpenGL tells me to install an Open GL driver or something. The PC is unusable with the drivers installed. I have an Asus K8V duelex with a VIA K8T800 chip set.

Anyone know what's up? I've tried CP, CCC, and even Asus drivers. Thanks for your time and help!
Has anyone had this error before? I don't know what to do, and I'd rather not format.
I had the error when I tried to use an AIW 9800 that was designed for an embedded OS system.

You may have one of those...maybe flashing the bios could help.
Found it...it's a driver cleaner problem. My problem was not the same as yours, yours is a result of using an older version of driver cleaner. The cleaner removes files that the ATi drivers do not install...in short, reload windows and dont use driver cleaner crap.
I reformatted, and installed the drivers clean. No, message, but the symptoms still exist. I wish AGP cards weren't such a ripoff these days. 2D is painfully slow. 3D is gone and the drivers don't really recognize the card properly. Could there be physical damage to the card?
The BIOS updates for my board only fix stupid things, like the "&" key not working on some generic keyboard that no one owns.
What ATI driver version you using for the radeon? is the VC a retail ATI one?

I use latest and between versions i use driver cleaner 1.5 PE with no issues at all
I still dont get why anyone uses driver cleaner, it's useless. Ever since I quit using it...I've had no driver problems...simply uninstall old, install new. Works every time. Even when going from nvidia to ATi, and even going back.

Oh well...just my little rant, you use it if you want. :D
OldMX said:
What ATI driver version you using for the radeon? is the VC a retail ATI one?

I use latest and between versions i use driver cleaner 1.5 PE with no issues at all

Everything I could think of. Omega, VIA, Regular... Even tried older ones.
Yeah, I've had exactly the same problem with my X1800XL drivers. The issue was also accompanied by my system occaisonally hanging on startup and I eventually just reformatted and the problem went away altogether.

Before reformatting, however, I tried something that may have worked (it seemed to have worked until I updated to newwer drivers the old-fashion way and the problem came back):

somewhere on the net said:
> Had the same problem with the "zero display error" so here´s what i
> did:
> Uninstall everything that has to do with ATI, but keep the
> installation directory that the "catalyst installer" creates
> "..\ATI\SUPPORT\.... : "controlpanel-add remove progs-ATI". Reboot &
> when XP discovers new hardware, do a manual installation and let XP
> search for the driver *.inf files in
> ..\ATI\SUPPORT\wxp-w2k-catalyst....\DRIVER\. Done with the driver
> files. Now you have to install the WDM & CPANEL aswell. Open
> ..\ATI\SUPPORT\wxp-w2k-catal.....\WDM & \Cpanel directories & run
> "setup.exe" in both directories. Reboot when prompted,
> DONE!!!!!!!!!!!!!!!
To get this procedure to work I had to do a couple of things different, but I'm sure that you can figure it out.