WoW under vista

El Nacho

Noobie Cheese
Joined
Jan 22, 2002
Messages
2,258
x2 4400+
2gig of ram
7900gt
nforce 6100
1280x1024 just about everything at max

So i grab my copy off MSDN to give a try. Install Ultimate (sp?) 64bit version. Using most of the default drivers that shipped with it, but I did grab the latest video driversoff of nvidia's site (they dont have updated drivers fro the board yet). Get WoW installed and what do i notice.....at least half the FPS.

I usually get around 50fps regardlless of where im at, but just running around in Ironforge I notice that Im dipping down into the low teens. Anyone else have these issues or a solution? Im in the process of installing other games now.
 

NoxTek

The Geek Redneck
Joined
May 27, 2002
Messages
9,300
It's Windows Vista.

Windows Vista although released to RTM is not available for consumer purchase until January. Because Vista isn't scheduled to be widely available until January driver development is somewhat lacking right now especially when it comes to video chipsets.

Be thankful you even got it to run on Windows Vista... even at half the FPS.
 

El Nacho

Noobie Cheese
Joined
Jan 22, 2002
Messages
2,258
yeah i know it wont be out to Jan :) But its not like we are talking about beta here. This is the final version

I guess im just surprised that the drivers are still so crappy. I've tried turning off all the eye candy to see if it was that and its not. With only about a month or so left, you would think the drivers would be in better shape. Do most other games suffer the same fate?
 

Mr. Stryker

Supreme [H]ardness
Joined
Mar 15, 2005
Messages
5,219
Also you mentioned it's the 64-bit version. They're not exactly the best right now, still not mature yet. It took a while to mature up Win XP x64.
 

Drexion

[H]ard|Gawd
Joined
Jul 14, 2004
Messages
1,421
El Nacho said:
yeah i know it wont be out to Jan :) But its not like we are talking about beta here. This is the final version.
Yes its the final version of Vista - but ATI and nVidia's drivers for Vista have not matured as yet. Only after the official release in Jan will third party companies start to release and update vista drivers regularly.
 

Nasty_Savage

Fully [H]
Joined
Mar 19, 2001
Messages
22,818
I'm running 32 bit on my Inspiron and I'm getting all whackyness myself, but I think it has something to do with the Audio drivers. Though I suppose it may have something to do with the nvid drivers...not sure.
 

dekard

2[H]4U
Joined
Nov 1, 2004
Messages
2,190
El Nacho said:
I did grab the latest video driversoff of nvidia's site (they dont have updated drivers fro the board yet).

You really need to revert to the drivers on the install dvd. Believe it or not they are more recent than the ones on their website. 96.86 is the version on the dvd.
 

El Nacho

Noobie Cheese
Joined
Jan 22, 2002
Messages
2,258
I'll check and see what version I am using when I get home. The one on the nvidia site just got posted ont he 17th. I'll give it a try though :)
 

NeghVar

2[H]4U
Joined
May 1, 2003
Messages
2,553
We have it installed on one of our Vista demo systems where I work. It runs great.
 

jester1176

[H]ard|Gawd
Joined
Sep 26, 2002
Messages
1,553
the only issue i have with WoW in vista is the audio. performance otherwise is great.
 

El Nacho

Noobie Cheese
Joined
Jan 22, 2002
Messages
2,258
for those of you saying that wow runs great under vista. Could you post what your running (version of vista and hardware)?
 

ServerKing

[H]ard|Gawd
Joined
Mar 11, 2005
Messages
1,730
If your having issue i bet money your running the new creative audio card (I seriously just had a brain freeze) My roomate has issues with the creative drivers and vista doesnt care too much for them. Was causing all sorts of issues with his games running. Thats was RC1
 

El Nacho

Noobie Cheese
Joined
Jan 22, 2002
Messages
2,258
nope. I'm using the onboard ac97 sound. Didnt get a chance to try out new drivers last night. Too much football :)
 
Top