wow help

Aug 14, 2003
when i get to the account log in screen, i enter my account and it does that whole "loggin in, hand shake thing" then when its says "connected" it just sists there, not frozen, when i hit cancel it takes me to the realm selection screen, i select my raelm and then it goes back to the "connected" screen for logging on to the realm and sits there, not frozen.

same thing is happening for me and another friend. the servers must be messed up right now.
Same here, to. Servers went down for repair/upgrading today, so I assume they still have a few kinks to work out. Wait a few hours, they should be back soon ^^
It's up and working now. The problem I had was as soon as the maintenance was complete, I got in right away and it set me in Test 17... Everytime thereafter I got to the same point you did and it just locked up/disconnected. When it says connected, click cancel and it will re-assign what Test region you are in. From that point I went straight in. Don't know if that will help you.

To reassign does one just click on another server? I'm giving this a try
interesting...i still can't get in even if i click a realm. just says logged in and that's it. hope they get it worked out soon i want to play!
Okay so i tried this and its still dying and not connecting, but at least it says its not connecting instead of just sitting there with its thumb up its ass, arg! I need to be playing, how long does the open beta run, the website is down.
The FAQ on their main forum does not determine how long the beta will run. Could go until release could end today. Who knows, until they announce something.
I just tried logging in again and I went through the normal processes, and then it says "session expired"? wtf is up with that?!