Windows remote desktop connection not working.


Limp Gawd
Sep 24, 2005
I can connect to my laptop from my desktop, but not the other way around. This error message comes up:

Remote connection is enabled on both machines, and it makes no difference with windows firewall disabled.

Additionally, the desktop is visible on the network map as viewed from the laptop.

Any information would be greatly appreciated.
Last edited:
Agh, there is a group policy for this. I'll see if I can find it.
Try checking this

  • Computer Configuration – Administrative Templates – Windows Components – Remote Desktop Services – Remote Desktop Session Host – Connections.
  • Allow users to connect remotely using Remote Desktop Services (enable or disable)
Don't disable the firewall, allow remote desktop connections. I have seen in some cases where disabling the firewall will turn on a default firewall rule that blocks everything.
Can you connect if you type in the machine IP or does it still not connect?
If you can connect via IP, that means your DNS tables are out of whack and your router may need to be rebooted and/or you need to run ipconfig /flushdns and ipconfig /registerdns.

I had that issue before...DNS tables got out of whack once I switched from U-Verse to Charter....had to re-register the DNS tables in Windows because they had changed in my router. Once I did that I was able to RDP using hostname again.

You can also trying pinging via IP vs hostname....that'll show the same as well. If the DNS tables are not right, you won't be able to ping via hostname (but IP will work).