Windows Firewire interface issue (IP over iee1394)


Sep 28, 2004
I posted this in the "networking section" but it may have been too windows specific. 10 days, no bites. I'm sure a format/reinstall will fix it, but thats a suckers way out.

WindowsXP Pro sp2, totally updated.

I have a setup where I wish to use my 1394 (firewire) connection over IP to connect to a 'nix box for a point-to-point network. 'Nix box is set up properly, and the iee1394 interface runs IP over it like a champ. Windows XP-pro SP2 box is at a loss. It "used to work, now it don't."

WinXp has a "1394 connection" and "1394 connection #2" listed. (fine, I have 2 FW interfaces, I just want to use one of them). I know for a fact which interface is which, so physical confusion can be left out, I know which port corresponds to which interface in windows. Cable is good, just in case, I have tried 2 other cables. I do not believe I have a physical layer problem. Windows "recognizes" both "Net Adapters" in device manager. It claims to be working.

I have Client for MS networks File and Printer sharing for MS Networks, and TCP/IP "checkmarked." My setup is to go into the properties of the 1394 connection and configure the TCP/IP settings. The IP of this interface will be a non-routable IP (with a subnet and NO GATEWAY, nor DNS servers; I dont want this interface to attempt to go anywhere but to the box sitting 2 feet away) and the far end machine is configured for (same subnet, no gateway).

1)Zero connectivity, no traffic at ALL is being passed across my windows interface. I go to status of the connection, support tab and nothing is listed. No IP info, no nuttin. I hit the "repair" button and the message "TCP/IP is not enabled for this connection. Cannot Proceed."

Steps I've taken:
1)Unchecked TCP/IP, rebooted. Re-checked TCP/IP re-entered info. No change
2)Uninstalled 1394 Net Adapter(s) from device manager, rebooted. No change, but now I had 1394 connection #3 and #4 (where it used to be 1394 connection and 1394 connection #2). Still no connection
3)ran "netsh int ip reset" command rebooted. No change
4) ran "netsh int ip reset" command followed by "netsh winsock show catalog" command, rebooted. No change.
5) uninstalled 1394 net adapters via device manager, and re-ran the two "netsh" commands listed in step 4. No change
6) Uninstalled 1394 net adapters via device manager, went into registry (regedit in normal mode) and removed network keys listed in hkey_local_machine\system\controlset001\control\network that described the 1394 connections, re-ran the two "netsh" commands from step 4, rebooted. No change - other than the positive step that now I have "1394 connection and 1394 connection #2" instead of #3 and #4.

I'm at a loss. I dont know what else to try. Yes the OBVIOUS answer is "get another GigE card and crossover cable and be done with it." However, thats the sucker's way out. All I want is a single point-to-point IP connection over firewire to xfer files to another box without clogging up my 100Mbit connection.