Windows 7 x64 Ultimate - Startup with Scroll Lock On

Discussion in 'Operating Systems' started by Dohclude, Feb 25, 2010.

  1. Dohclude

    Dohclude Limp Gawd

    Messages:
    146
    Joined:
    Nov 19, 2004
    I have an interesting problem that I have not been able to fix. It all started when my keyboard died and I had to get a new one. I bought a fairly cheap one from ebay, with illuminated keys. My old keyboard also had illuminated keys, but it has transparent keys and EL backing for the illumination as well as it's own on/off button to turn the lights on and off.

    The new keyboard has black keys, with transparent letters and uses LED lighting for the illumination, but the backlight turns on and off with the scroll lock for some crazy reason. I use my keyboard in the dark quite a bit which is why I always get these illuminated keyboards, but when I boot into windows the scroll lock is always off by default.

    I wanted the backlight on as soon as I turn on the computer, but my motherboard's BIOS has no option for it ( Gigabyte GA-EP43-DS3l , Award BIOS I believe ). So I wanted it on at least for the login screen and after login to desktop. I did some google searches and found these keys which should enable this:

    "HKEY_CURRENT_USER\Control Panel\Keyboard\InitialKeyboardIndicators"

    and also

    "HKEY_USER\Control Panel\Keyboard\InitialKeyboardIndicators"

    Setting these keys to a value of "6" is supposed to enable the NumLock and ScrollLock at the login screen as well as after login to the desktop. Well, it doesn't work and the values keep changing back to a value of "2" which is NumLock only.

    I have searched and searched for hours and even tried writing a VB script to change the values in the registry when the computer shuts of and starts up but nothing works. I found a program called NumLocker, but it starts after login and runs in the background which I am not fond of.

    I just want my ScrollLock to always be on no matter what. Is there any way to achieve this without any crapware running at startup. Any ideas?
     
  2. supernova874

    supernova874 n00b

    Messages:
    1
    Joined:
    Nov 12, 2014
    I Have find this old forum post from search in Google, i had the same problem with a Keyboard from Coolermaster , the solution i made it my self using a script i have find in another site that was made for change num-lock state.

    You need to open Notepad and copy-paste the folowing script:


    Set wshShell =wscript.CreateObject("WScript.Shell")
    Dim i
    i=0
    do while(i<=0)
    wscript.sleep 200
    wshshell.sendkeys "{SCROLLLOCK}"
    i=i+1
    loop


    Now save it as .vbs (any name)

    As a last resort you need to create a task to your pc to start it on log in.
    In windows 7 Start on search type : task and you will find the Task Scheduler , start it and create a new task in "Task Scheduler Library" by right click and Create Task ;now in trigger section create new trigger and select Begin The Task : At Logon and Any User , then in action create new Start a Program and select your script , finaly in Settings Section select: Allow task to be run on demand , also Run task as soon as possible... and as last "If the task is already running , then the following rule applies : stop the existing instance. Now reboot your system and it will turn scroll lock on .

    If any help needed ,dont mind to ask .

    I Hope this helps , anyone with the same problem.
     
    Last edited: Nov 13, 2014
  3. Tom_S

    Tom_S Limp Gawd

    Messages:
    323
    Joined:
    Dec 30, 2011
    I assume you meant "HKEY_USERS\"the users name"\Control Panel\Keyboard\InitialKeyboardIndicators". I think if you change each of those users keys, including ".default" and change the current user too the setting you want it will stay set, if not use 2147483654 instead of 6.

    Windows will try to initialize the keyboard at whatever the state was at shutdown but the above solution has been persistent for me using the long decimal number instead of the abbreviated (6) hexadecimal number.