Windows 10 time settings (I've tried, what seems like, everything)

Joined
Sep 11, 2020
Messages
12
Hi all. Thanks for your time in reading about my problem here. I've tried to find a solution on this forum and elsewhere on the internet, but to no avail.

System information:
Motherboard: B450 Aorus Elite (brand new, correct battery installed, correct time settings in BIOS)
OS: Windows 10 Pro (Registered and activated)
Browser: Chrome

Problem:
My time is 1 hour behind when the system settings are correct. Internet time syncs 1 hour behind regardless of the server I choose to sync to and times in websites that read my system clock are off.

In Date & Time settings:
Set time automatically - On
Set time zone automatically - On
Synchronize your clock - Successful at [always shows 1 hr before I manually sync it]
Time zone showing correct @ Central Time (US & Canada)
Automatically adjust clock for Daylight Savings Time is checked
Synchronize with an Internet time server is checked
Server is time.windows.com (doesn't matter which server I choose or enter manually, problem still persists)

In Services App:
Windows Time is running and set to automatic

I have tried:
restarting Windows Time in the Services App
unregistering and re-registering Windows Time DLL file and the EXE process
forcing sync through command prompt (as Administrator)

When I manually set the time it remains the same (correct) upon restart, and the process in the Services App is changed from "Automatic" to "Manual". Further, and strangely, my time in Discord (browser, not client) is 1 hour behind and my time on Facebook is 2 hours behind. I can't figure out what is going on and any help you can provide would be very appreciated.

This wasn't a problem until just recently around the same time that some updates installed [image attached].

updates.png
 

modi123

Supreme [H]ardness
Joined
Sep 6, 2006
Messages
5,892
Is everything off when you turn off 'set time zone automatically'?
 

travm

Gawd
Joined
Feb 26, 2016
Messages
658
You've set the wrong time zone.
Or possibly try setting a different time zone, then setting it back?
 
Joined
Sep 11, 2020
Messages
12
Turn off 'Set time zone automatically' and manual set appropriately.

These issues still persist...

When I manually set the time it remains the same (correct) upon restart, and the process in the Services App is changed from "Automatic" to "Manual". Further, and strangely, my time in Discord (browser, not client) is 1 hour behind and my time on Facebook is 2 hours behind. I can't figure out what is going on and any help you can provide would be very appreciated.
 

WarriorX

2[H]4U
Joined
Nov 18, 2006
Messages
2,101
Try running W10 in a VM (can use the built in VM tool, virtual box, whatever you want). See if the VM has the correct time, make sure all of the settings are the same. That would tell you if something is with the install or something else I would think.
 

auntjemima

Supreme [H]ardness
Joined
Mar 1, 2014
Messages
6,505
I have the same problem. Have for years.

If I change it from auto to manual and back to auto it will update to the proper time, which tells me it knows my timezone and the time it should be. But each reboot gives me the same scenario.
 

travm

Gawd
Joined
Feb 26, 2016
Messages
658
Is your country set properly? Some countries don't observe daylight savings time
 
Last edited:

vick1000

2[H]4U
Joined
Sep 15, 2007
Messages
2,061
Clear location history, and manually set location.Search your gateway/ router IP and see where it shows your geolocation.
 
  • Like
Reactions: travm
like this

SmokeRngs

[H]ard|DCer of the Month - April 2008
Joined
Aug 9, 2001
Messages
16,684
Every single time I've run into this issue it was because Windows was trying to use automatic time zone. As soon as that was disabled and the time zone set manually it was no longer a problem.
 
Joined
Sep 11, 2020
Messages
12
hat would tell you if
In settings (during setting up the VM) it has a box that is unchecked to set machine time to UTC time. I should leave that unchecked when I install the VM and do a normal setup and make sure the settings are the same, correct?
 
Joined
Sep 11, 2020
Messages
12
Try reinstalling Windows.

Issue persists.

Is your country set properly? Some countries don't observe daylight savings time

It is.

Clear location history, and manually set location.Search your gateway/ router IP and see where it shows your geolocation.

Gateway / router IP search detects appropriate time and location. Clearing and manually setting location does not work.
 

WarriorX

2[H]4U
Joined
Nov 18, 2006
Messages
2,101
In settings (during setting up the VM) it has a box that is unchecked to set machine time to UTC time. I should leave that unchecked when I install the VM and do a normal setup and make sure the settings are the same, correct?
I would think leaving it unchecked is fine. Could try it with it on and off if you wanted to be sure.
 

auntjemima

Supreme [H]ardness
Joined
Mar 1, 2014
Messages
6,505
My PC is the same. No domain, timezone is correct, location is correct. Every reboot I have to change it to manual, which doesn't affect the time and then switch it back to automatic with automatically refreshes and displays the correct time.

Makes no sense.

I am running an older version of Windows 10, though.
 

Nobu

Supreme [H]ardness
Joined
Jun 7, 2007
Messages
4,756
Last person who reported issued with timezones in win10 here had it solved when he reinstalled, iirc.
 
Joined
Sep 11, 2020
Messages
12
Last person who reported issued with timezones in win10 here had it solved when he reinstalled, iirc.

This really is my last option. Since having posted this thread, I have tried uninstalling and reinstalling the BIOS drivers, new CMOS battery, etc. The Virtualbox test showed the same problem though, so I'm not sure if a OS reinstall will fix it, but it seems like my last option. I'm going to try it and report back here if it fixed my issue.

I mean, I really have tried everything.
 

modi123

Supreme [H]ardness
Joined
Sep 6, 2006
Messages
5,892
When you are in the control panel, hit up the 'region'. Is that set to your specific country and language preference? Say it's off and using GB and not US or something else.
 

modi123

Supreme [H]ardness
Joined
Sep 6, 2006
Messages
5,892
Last place would be your bios providing wrong information - regardless of your checking - or splunking into the registry.
 

Nobu

Supreme [H]ardness
Joined
Jun 7, 2007
Messages
4,756
Check your router/access point's time settings. Your PC may be inheriting the wrong settings from there.
 

Shoganai

Gawd
Joined
Dec 5, 2018
Messages
876
This really is my last option. Since having posted this thread, I have tried uninstalling and reinstalling the BIOS drivers, new CMOS battery, etc. The Virtualbox test showed the same problem though, so I'm not sure if a OS reinstall will fix it, but it seems like my last option. I'm going to try it and report back here if it fixed my issue.

I mean, I really have tried everything.
You told me you reinstalled Windows, which you did not. Installing Windows in Virtualbox is not the same thing. I had a buddy who bought their computer in New Zealand and nothing I did could make the timezone set properly to the United States, even turning off the automatic setting and doing it manually. The only thing that worked was reinstalling Windows. Then it worked normally again.
 

vick1000

2[H]4U
Joined
Sep 15, 2007
Messages
2,061
You could change the server that Windows syncs with for updating date and time, or disable sync from there. Control panel>Clock and region>Set the time and date>internet tab>advanced settings
 

bigdogchris

Fully [H]
Joined
Feb 19, 2008
Messages
18,206
Open Maps - Go into settings and choose a default location (or search default location in settings).
Go back to time settings and set to choose timezone automatically (yes this relies on maps data).
 
Joined
Sep 11, 2020
Messages
12
Hiya. Sorry took me so long to reply. I was fall camping with the family. I didn't get a chance until just recently to resolve the issue with any amount of time to dedicate. I hate abandoned threads, so I'm back to say what worked.

You told me you reinstalled Windows, which you did not. Installing Windows in Virtualbox is not the same thing. I had a buddy who bought their computer in New Zealand and nothing I did could make the timezone set properly to the United States, even turning off the automatic setting and doing it manually. The only thing that worked was reinstalling Windows. Then it worked normally again.

I actually did reinstall Windows 10. It just didn't fix the issue. I reinstalled Windows 10 a second time and that resolved it. There is no difference between my initial installation and the subsequent 2 reinstallations. I don't know why it was in error for the first two installation and not the third because all of the setting were the same (BIOS time clock, setup options, etc.). I was a hardware tech back in the early 2000s and I know a lot has changed since then, so it may be something I am just unfamiliar with, but I did go through the typical setup process when setting up this machine (on first boot check BIOS settings such as time, boot order, etc.).

I looked and looked to try to avoid a second reinstall (as I was convinced it wasn't the installation after the second time) but that appears to be everyone's fix. I was skeptical of trying this a second time because I was so meticulous on my setup and first reinstallation of Windows.

I'm sorry I can't be more informative with what was causing the issue other than what I've provided here. If anyone else has ideas for future visitors to the forums, that would be cool. The other threads that I searched up before posting this one were not very informative (many abandoned or became phallus measuring contests). If you need any more system information from me to work on a more practical fix than reinstallation, I can provide any information you need towards that end.

Thanks for all of the replies and your help. Cheers.
 

Ready4Dis

2[H]4U
Joined
Nov 4, 2015
Messages
2,367
Is there some DLS (Day Light Savings) setting that is causing it to set the time one hour off? That's what i've seen in the past on things that have the right time zone, but wrong DSL (or have it not set to auto, or you're in an area that it has the DLS incorrect).
 
Top