windows 10 + server 2012 domain (how do i get a no password share ?)

Discussion in 'Operating Systems' started by troyquigley, Mar 4, 2016.

  1. troyquigley

    troyquigley Guest

    i have a windows 10 workstation on a 2012 server domain.

    how can i make a shared folder on the w10 workstation that does not require a password ?

    is there a group policy settings or registry entry ?
     
  2. dbwillis

    dbwillis [H]ardness Supreme

    Messages:
    7,255
    Joined:
    Jul 9, 2002
    share the folder with 'everyone' and give it read-write perms?
     
  3. MrTroy03

    MrTroy03 Limp Gawd

    Messages:
    422
    Joined:
    Feb 12, 2008
    I copy/pasted this from another thread I posted in so I don't need to re-type it all, should give you the jist.
    1. On all PCs I go into Advanced Sharing from the Network And Sharing center.
    2. Go to Advanced sharing settings on the left hand side.
    3. For Private network section, set it to "Turn on Discovery","Turn On File & Print Sharing" and "Use user accounts and passwords to connect to other computers"
    4. Still in Advanced, expand "All Networks" and "turn off password protected sharing". It will ask you to log out. Do so and log back in.
    5. Once you are logged back in go back and check all of these settings. For some reason the last option sometimes gets set back.
    For the network share, on the PC that HOSTS the network share:
    1. Right click on the shared folder, go to properties.
    2. On the sharing tab, click Advanced sharing, click permissions, and for the everyone group give the Modify permission and hit OK twice to get back to the folder properties window.
    3. Go to the security tab, click edit, click "Add" and add the everyone group by typing in the word Everyone.
    4. Set Everyone to Modify and save and close all properties.
    Other tips
    1. If you have software firewall other than Windows firewall, you will need to allow incoming and outgoing traffic on the Windows file and printer sharing ports.
    2. Make SURE the network type on ALL the computers is "Private".
     
  4. troyquigley

    troyquigley Guest

    "turn off password protected sharing" - no longer appears AFTER you have joined a domain

    these steps still require credentials
    For the network share, on the PC that HOSTS the network share:
    1. Right click on the shared folder, go to properties.
    2. On the sharing tab, click Advanced sharing, click permissions, and for the everyone group give the Modify permission and hit OK twice to get back to the folder properties window.
    3. Go to the security tab, click edit, click "Add" and add the everyone group by typing in the word Everyone.
    4. Set Everyone to Modify and save and close all properties.