Windows 10 BSOD after Windows 7 upgrade, please help

vortexware

n00b
Joined
Mar 22, 2020
Messages
58
So just like everyone else i had to update to Windows 10, i have 2 computers in the house that were running Win 7 with no issues at all, my main gaming rig updated to Win 10 with no issues at all, my secondary gaming rig started BSODing after the upgrade at complete random times with a "Critical Structure Corruption" BSOD, the 109 code which indicates a driver issue, being an IT i have made several cloned drives in case something happens, good thing i did. I have tried just about everything from reseating RAM, testing RAM, checkdisk on all drives, SFC, updated drivers, uninstalled old programs, run stress tests, no matter what i do this issue is still there ONLY on Win 10, this issue does not EVER occur on Windows 7, i have also tried different BIOS updates, no change, heres my rig in summary:

Core i7 Skylake, MSI Geforce 960, Samsung Evo SSD, Win 7 and 10, 16gb RAM at 1600, 1k Corsair PSU, Corsair water cooled CPU

Here is the dumb file, i am only posting this one since 100% of the time it is the same exact thing: Win 10 Crash Dump Download

I have the choice to go back to a 100% working Win 7, whoever i want to make this work, i am completely out of ideas since i have tackled this issue for about 2 weeks now, please help me, any help is greatly appreciate it, thank you in advance
 

IdiotInCharge

[H]F Junkie
Joined
Jun 13, 2003
Messages
14,495
I didn't see Safe Mode among your list; that should eliminate driver issues, as a point of testing. Can you let us know what you've done in that regard, or take a look if you haven't?
 

vortexware

n00b
Joined
Mar 22, 2020
Messages
58
Alright so SAFE MODE is something i have no tested yet, what i have tried so far and currently testing is diagnostic bootup, basically with no services running other than Windows as well as all startup programs disabled, waiting to see what happens, as far as SAFE MODE, what can i do since i have no idea which driver is causing the issue, the dumb file does not tell me anything unless you guys can analyze it and maybe pin point which driver, all i get in bluescreen view is ntskkrnl with Critical Structure Corruption when blue screen happens, i am suuuuuuper lost, and why is it only happening in Win 10 amazes me, ohh i have also did a C drive cleanup, same result.....ohh and i even tried enabling XMP in BIOS for RAM, same results
 

vortexware

n00b
Joined
Mar 22, 2020
Messages
58
I have Windows booted in diagnostics mode for about 30 min now, so far so good, if i go in Safe Mode, what can i test if i have no idea which driver, service is causing the issue, any chance you can take a look at the dump file or tell me what to do next, i am super lost atm
 
Last edited:

IdiotInCharge

[H]F Junkie
Joined
Jun 13, 2003
Messages
14,495
I have Windows booted in diagnostics mode for about 30 min now, so far so good, if i go in Safe Mode, what can i test if i have no idea which driver, service is causing the issue, any chance you can take a look at the dump file?
I wouldn't know where to begin with the dump file.

What I can tell you is that if it's a driver issue, you should probably do a clean install and build it back up, taking your time with the drivers. This is the fastest way back to a working system.
 

vortexware

n00b
Joined
Mar 22, 2020
Messages
58
I would really love to do that but the install has about 10 years of data and settings tailored to me and my wife, rebuilding from scratch would take 1 month, i need to figure this out, with yalls help of course
 

pendragon1

Fully [H]
Joined
Oct 7, 2000
Messages
20,457
remove every device and unneeded drive, turn off extra ports in bios and disable all startup items. see if that helps. if it does start adding things back.
 

vortexware

n00b
Joined
Mar 22, 2020
Messages
58
Thats what i am doing right now, so far i have all startup devices disabled as well as all non Windows services disabled, il see how this goes, it pisses me off that Win does not give any info during a dumb and they removed the BlueScreen troubleshooter, i just dont get that...do you see anything in that dump file that can maybe be a clue or narrow down the issue?

UPDATE: so far running Windows with no startup items as well as all non Windows services running seems to not BSOD the system, what non Windows services do i really need?
 
Last edited:

AltTabbins

Fully [H]
Joined
Jul 29, 2005
Messages
19,929
Thats what i am doing right now, so far i have all startup devices disabled as well as all non Windows services disabled, il see how this goes, it pisses me off that Win does not give any info during a dumb and they removed the BlueScreen troubleshooter, i just dont get that...do you see anything in that dump file that can maybe be a clue or narrow down the issue?

UPDATE: so far running Windows with no startup items as well as all non Windows services running seems to not BSOD the system, what non Windows services do i really need?
Sounds like something you have that didn't like the upgrade with windows 7 to 10. Maybe an older version of software that might have an update to fix incompatibilities with windows 10?
 

vortexware

n00b
Joined
Mar 22, 2020
Messages
58
Well it BSOD again, i turned on startup item again, i checked event log and i consistently get these issues from the Kernel before its bugcheck:

The driver \Driver\WudfRd failed to load for the device HID\VID_17A0&PID_0310&MI_03&Col02\7&2630620a&0&0001

The driver \Driver\WudfRd failed to load for the device ACPI\PNP0A0A\2&daba3ff&1

I even tried uninstalling USB devices, at one point it BSOD with a IRQL, possibly due to be trying to uninstall the host controller?
 

pendragon1

Fully [H]
Joined
Oct 7, 2000
Messages
20,457
The driver \Driver\WudfRd failed to load for the device HID\VID_17A0&PID_0310&MI_03&Col02\7&2630620a&0&0001
this refers to a mic. got one plugged in?

The driver \Driver\WudfRd failed to load for the device ACPI\PNP0A0A\2&daba3ff&1
and this leads back to "asus com" service/software. have all the mobo drivers installed? what mobo is iy anyways?
 

IdiotInCharge

[H]F Junkie
Joined
Jun 13, 2003
Messages
14,495
I would really love to do that but the install has about 10 years of data and settings tailored to me and my wife, rebuilding from scratch would take 1 month, i need to figure this out, with yalls help of course
You can have it working in an hour.

I get that you'd want to get it configured back to your comfort zone eventually, but that's something that's going to take time regardless moving to Windows 10.
 

OliverQueen

Limp Gawd
Joined
Apr 17, 2019
Messages
170
You can have it working in an hour.

I get that you'd want to get it configured back to your comfort zone eventually, but that's something that's going to take time regardless moving to Windows 10.
THIS!!!!

No matter how much you hate resetting everything up to how you want it, if it means that you get a machine that works instead of flogging a dead horse for weeks on end & getting nowhere. There are times where you need to bite the bullet & just do what is required. You can back up data to an external source so that won't be lost & can then copy it back afterwards. That will take a lot less time than going around trying to fix something that may not even be able to be fixed without a wipe & reinstall. Even the most exerienced of techs will have done this numerous times themselves instead of trying to work a way round something. Even if you do fix the problem, there is nothing to say it won't appear again sometime down the line & then you do need to reinstall without being able to backup the data.
 

vortexware

n00b
Joined
Mar 22, 2020
Messages
58
Alright quite a few replies so i am going to try and respond to all, i really appreciate your help so far guys, here i go

pendragon1 - i have tried going through the dump files myself, can't find anything, i am also looking at the event viewer, i get stuff like driver didn't load which you replied to, how did you identify the drivers anyway, program? Also yes i have a Samson Meteor mic plugged in as well as the Logitech 920 camera microphone that's incorporated, both seem to be working fine tbh, and i have no idea which Asus driver it wants as i have always had no ! in the manage tab, all drivers installed, Mobo is an Asus Maximus VII Hero
IdiotInCharge and OliverQueen - this is of course an option and i do have cloned hard drives and of course all my stuff is backed up, it irritates me that i have upgraded other machines as well with no issues, Win 10 should by now have 0 issues upgrading from OS to OS its 2k20 FFS, i guess my biggest concern is that i have an Objectdock Top bar that i absolutely do not want to reconfigure, i wonder how to save the settings so i can reinstall

I have left the computer running overnight, i had Microsoft services turned on and only Nvidia and Start10 as the non Microsoft items, as startup items i had my mouse driver and my stardock top bar, no luck, i found like 6 BSOD overnight, same "Critical Structure Corruption" BSOD dumps, what i did try yesterday and seems to be no BSOD is using "Diagnostics Bootup" which i believe turns off all services including Windows services, could it be a Windows service issue? Why isn't the dump file showing anything, this is rediculous, also may i remind you guys that just about all settings and configuration is on my primary machine and it is running like a champ, that is also my main gaming machine so i am really happy about that, need to figure this out, it cannot be impossible to fix can it?
 
Last edited:

IdiotInCharge

[H]F Junkie
Joined
Jun 13, 2003
Messages
14,495
Win 10 should by now have 0 issues upgrading from OS to OS its 2k20 FFS
Zero issue upgrades don't exist. Apple has issues. Linux has issues. Phones have issues.

The upgrade routine cannot account for every variable.

You can either keep fighting with it, or you can move on and start getting work done.
 

vortexware

n00b
Joined
Mar 22, 2020
Messages
58
IdiotInCharge - Good point and i hear you, this is my secondary computer and my wife mostly uses it so its not THAT big of an issue as she also has a laptop she uses

Anything else i can try guys, any ideas, as you can see i would really like to fix it for obvious reasons as well as being a tech i really need to know whats going on, helps me in my job in the long run
Any programs you guys know that i can try for Services and see which one is not working correctly?
Also what happens if i turn off dump file and reboot in the recovery options mentioned here: Dump Settings

I am running version 1909 which is known to have issues, any way i can install an earlier version like 1809 etc?

How can i use Driver Verifier to rule out the bad driver?
 
Last edited:

pendragon1

Fully [H]
Joined
Oct 7, 2000
Messages
20,457
Alright quite a few replies so i am going to try and respond to all, i really appreciate your help so far guys, here i go

pendragon1 - i have tried going through the dump files myself, can't find anything, i am also looking at the event viewer, i get stuff like driver didn't load which you replied to, how did you identify the drivers anyway, program? Also yes i have a Samson Meteor mic plugged in as well as the Logitech 920 camera microphone that's incorporated, both seem to be working fine tbh, and i have no idea which Asus driver it wants as i have always had no ! in the manage tab, all drivers installed, Mobo is an Asus Maximus VII Hero
IdiotInCharge and OliverQueen - this is of course an option and i do have cloned hard drives and of course all my stuff is backed up, it irritates me that i have upgraded other machines as well with no issues, Win 10 should by now have 0 issues upgrading from OS to OS its 2k20 FFS, i guess my biggest concern is that i have an Objectdock Top bar that i absolutely do not want to reconfigure, i wonder how to save the settings so i can reinstall

I have left the computer running overnight, i had Microsoft services turned on and only Nvidia and Start10 as the non Microsoft items, as startup items i had my mouse driver and my stardock top bar, no luck, i found like 6 BSOD overnight, same "Critical Structure Corruption" BSOD dumps, what i did try yesterday and seems to be no BSOD is using "Diagnostics Bootup" which i believe turns off all services including Windows services, could it be a Windows service issue? Why isn't the dump file showing anything, this is rediculous, also may i remind you guys that just about all settings and configuration is on my primary machine and it is running like a champ, that is also my main gaming machine so i am really happy about that, need to figure this out, it cannot be impossible to fix can it?
well, the first error is to do with that mic. so i'd uninstall it and see if there is newer drivers for w10. the second error is probably to do with the asus control software. so i'd remove anything labelled asus and then download any new version from their site.

I am running version 1909 which is known to have issues, any way i can install an earlier version like 1809 etc?
nope, not with out a complete reload.
 

vortexware

n00b
Joined
Mar 22, 2020
Messages
58
What about doing an upgrade with only the KB and mouse connected, the plugging them in? My advantage is that i have the other cloned Win 7 SSD i can just pop in and try different stuff anytime, let me know pendragon1

But can a simple thing as a mic and asus drivers not loading cause a "Critical Structure Corruption" bsod, i thought those usually generate an IRQL type bsod ehh?
 

pendragon1

Fully [H]
Joined
Oct 7, 2000
Messages
20,457
What about doing an upgrade with only the KB and mouse connected, the plugging them in?
uninstall them and then update maybe.

But can a simple thing as a mic and asus drivers not loading cause a "Critical Structure Corruption" bsod, i thought those usually generate an IRQL type bsod ehh?
possibly, thats what the errors you provided point to.
 

vortexware

n00b
Joined
Mar 22, 2020
Messages
58
Do you think the bsod is version related, what if i try and install version 1803 and see if the issue persists? Dunno, at this point maybe installing with nothing connected but KB and mouse might make sense, if no devices are plugged in does Win still carry over the drivers?
 

vortexware

n00b
Joined
Mar 22, 2020
Messages
58
Yeh i was thinking that, i tried last night to remove all devices in USB and it bsod with a IRQL, i assume you can only do that in safe mode?
Also how did you determine it was the mic and asus drivers? What program are you using?
 

Monkey34

Supreme [H]ardness
Joined
Apr 11, 2003
Messages
5,128
Your best scenario is make sure windows 10 activated, then do a full system image (if you have to roll back to 7 to do this, do it) if you don't have a recent backup.
Use the latest windows 10 media creation tool to make an install usb drive, format the drive and do a clean install.
It takes a while to get everything back to what you are used to, but it's the best way to get the OS stable.

In my experience, systems that BORK during the upgrade rarely work right moving forward, and If you DO get it to work, it will BORK a future update...or just never install one of the next rollups.

I've always been a hold-out for not doing a format/install to fix problems, but there are times it's the best answer.
 

pendragon1

Fully [H]
Joined
Oct 7, 2000
Messages
20,457
Yeh i was thinking that, i tried last night to remove all devices in USB and it bsod with a IRQL, i assume you can only do that in safe mode?
Also how did you determine it was the mic and asus drivers? What program are you using?
i just googled the info you provided "HID\VID_17A0&PID_0310" and "ACPI\PNP0A0A\2&daba3ff&1"
 

vortexware

n00b
Joined
Mar 22, 2020
Messages
58
Monkey34 - yeh i have a clone of my Win 7 install so there is no issue, i can swap out the ssd at any time, since i use the creation tool anyway can i just select, upgrade but don't keep anything option, this should put everything to default mode right?
pendragon1 - i see, just thought you used a program or something

My next question is: if i do a fresh install but still want my old settings back, can i use this: Transfer Program ??
 

pendragon1

Fully [H]
Joined
Oct 7, 2000
Messages
20,457
Monkey34 - yeh i have a clone of my Win 7 install so there is no issue, i can swap out the ssd at any time, since i use the creation tool anyway can i just select, upgrade but don't keep anything option, this should put everything to default mode right?
pendragon1 - i see, just thought you used a program or something

My next question is: if i do a fresh install but still want my old settings back, can i use this: Transfer Program ??
if youre going to reload, boot off the usb then install, skip the upgrade part.
nope nothing special the HID and ACPI stuff is all thats needed.
nope, thats programs moves apps and accounts, not settings.
 

vortexware

n00b
Joined
Mar 22, 2020
Messages
58
Man this is soooo annoying, anyway i believe if i have no services running and no startup items the bsod goes away, i was really hoping it was the mouse driver but it bsod even with that turned off, never had i had an issue running Win 7, i knew this would happen if i went to 10, so what are the downsides to staying on 7, i know there are machines on 10 that dont get updes since they are on 1703 or something older than a year, kinda same idea isnt it

I just dont understand why they removed the Blue Screen troubleshooter in 1909, im gonna try and install 1803 and see what it does, at least i have the bsod troubleshooter there
 
Last edited:

Armenius

Fully [H]
Joined
Jan 28, 2014
Messages
22,822
What about doing an upgrade with only the KB and mouse connected, the plugging them in? My advantage is that i have the other cloned Win 7 SSD i can just pop in and try different stuff anytime, let me know pendragon1

But can a simple thing as a mic and asus drivers not loading cause a "Critical Structure Corruption" bsod, i thought those usually generate an IRQL type bsod ehh?
Whatever the ACPI error is pointing to is the most likely culprit of the 109 error. Could be something as simple as a temperature sensor that is trying to be accessed by your motherboard software or otherwise. I would check if there is an ACPI driver update for your motherboard and install it. It actually wouldn't hurt to update the entire suite of platform drivers to Windows 10 versions from the manufacturer's website. I notice that the motherboard is the one thing you didn't list in your OP.
 

vortexware

n00b
Joined
Mar 22, 2020
Messages
58
I have an ASUS Maximus VII Hero, and yes when i first built the system, for some reason on bootup it said "CPU Fan Not Detected" i had to go into BIOS and ignore that fan, never had an issue in Win 7, i do have one of those hybrid CPU water cooler/fan system from Corsair, i am not sure why it woulnt detect the fan since its all installed no issues, i believe its one o those Corsair Hydro 110i CPU Cooler or something, that would be the ONLY hardware thing i can think of at the moment....
 

pendragon1

Fully [H]
Joined
Oct 7, 2000
Messages
20,457
Man this is soooo annoying, anyway i believe if i have no services running and no startup items the bsod goes away, i was really hoping it was the mouse driver but it bsod even with that turned off, never had i had an issue running Win 7, i knew this would happen if i went to 10, so what are the downsides to staying on 7, i know there are machines on 10 that dont get updes since they are on 1703 or something older than a year, kinda same idea isnt it

I just dont understand why they removed the Blue Screen troubleshooter in 1909, im gonna try and install 1803 and see what it does, at least i have the bsod troubleshooter there
its not 10's fault that there are incompatible 7 driver left in the system....
have you removed the mic drivers/software yet? how about updating the asus stuff? are you ignoring an easy step?
 

vortexware

n00b
Joined
Mar 22, 2020
Messages
58
pendragon1 I have been at work all day, i will remove these once i get home of course, read the statement above and tell me what you think about the CPU fan not detected, which never gave me an issue in Win 7 and tell me what you think
 

Monkey34

Supreme [H]ardness
Joined
Apr 11, 2003
Messages
5,128
Monkey34 - yeh i have a clone of my Win 7 install so there is no issue, i can swap out the ssd at any time, since i use the creation tool anyway can i just select, upgrade but don't keep anything option, this should put everything to default mode right?
pendragon1 - i see, just thought you used a program or something

My next question is: if i do a fresh install but still want my old settings back, can i use this: Transfer Program ??
Again, I reccomend a clean install, not the upgrade option.
The only transfer program I've ever tried was Laplink PC mover ultimate...and I only tried it once. It worked fine for all the files, and 90% of the programs. Many programs worked fine; the program, registry entries, activation, etc. all moved...........some ran but had to be re-activated.......one didn't work at all and had to be installed from scratch.
 

pendragon1

Fully [H]
Joined
Oct 7, 2000
Messages
20,457
pendragon1 I have been at work all day, i will remove these once i get home of course, read the statement above and tell me what you think about the CPU fan not detected, which never gave me an issue in Win 7 and tell me what you think
do you the fan plugged into the cpu fan header or the system fan header? windows wont give you a problem from that, the bios will complain.
 

vortexware

n00b
Joined
Mar 22, 2020
Messages
58
I know of the program Monkey34 i will look into it, also yes the fan is plugged in but after some research this issue is very common with the corsair hydro series, only work around for now is ignoring the CPU fan, so thats not the issue

On a side note, i have done all that you said pendragon1 but still the system bsod 2 times in 1 hour, i am running the system now in clean boot to see if it will bsod, thats about it so far

Also i am not sure if i can do a clean install as the upgrade tool keeps my current cd key, i can always buy another but id prefer not to

Monkey34 - if i use the mover ultimate, how can i do it since i am upgrading the system and that program uses a cable, can i save to external source?
 
Last edited:

pendragon1

Fully [H]
Joined
Oct 7, 2000
Messages
20,457
I know of the program Monkey34 i will look into it, also yes the fan is plugged in but after some research this issue is very common with the corsair hydro series, only work around for now is ignoring the CPU fan, so thats not the issue

On a side note, i have done all that you said pendragon1 but still the system bsod 2 times in 1 hour, i am running the system now in clean boot to see if it will bsod, thats about it so far

Also i am not sure if i can do a clean install as the upgrade tool keeps my current cd key, i can always buy another but id prefer not to
same bsod codes? you have any oc on the sytem?
the key is tied to your system now. if you do a clean install it will just activate itself.
 

vortexware

n00b
Joined
Mar 22, 2020
Messages
58
Yeh man same bsod, same 109 code, i even had no startup items nor non windows services running, i just booted in diagnostics mode to see if it will bsod before i do safe mode, never seen this before in all my Windows experience, i have always been able to fix a bsod, this is rediculous, i had absolutely 0 issues in Win 7 and i moved this ssd from my old computer, which i built in 07, built this system in 15 and absolutely no issues running XP and 7, what the f is going on....

And no i am not overclocking nothing, all stock

Can't do a clean install yet until i get the PCmover program, so i guess il experiment with version 1803
 

pendragon1

Fully [H]
Joined
Oct 7, 2000
Messages
20,457
so you removed the mic stuff and still get errors referencing the mic, same for asus stuff? anything new in events?
 
Top