Win7 x64Pro...DHCP "enabled" on an adapter not sticking?

Skripka

[H]F Junkie
Joined
Feb 5, 2012
Messages
10,792
I've had this issue for a while when hard-wired, but it was only once in a while. Now with a wireless adapter it is practically a daily occurrence. Powering off or sleeping my machine overnight makes no difference, will almost certainly happen the next day.

Symptom...out of the blue websites stop loading.

Fix:
Right-click on network sys tray icon>Troubleshoot Problems>Problem with an adapter>All Adapters....gets me this:



And for the record this is the one and only time a Windows "Try this repair" actually works. Windows claims it works in the troubleshoot prompts, and it actually does work.


Any great minds have an idea why on Earth Windows would keep turning DHCP off on my network interfaces...and more importantly how to stop it?
 

Liger88

2[H]4U
Joined
Feb 14, 2012
Messages
2,657
I'm guessing you already went through the adapter settings and made sure "Obtain IP address automatically" and "Obtain DNS automatically" is selected on the adapter?

Instructions:
http://windows7themes.net/en-us/how-to-enable-dhcp-in-windows-7/

Also would turn off IPv6. I've noticed more problems than not when having it on and not using IPv6. For whatever reason Microsoft thought it a brilliant move starting with Windows 7 to enabled IPv6 by default and assign it a higher priority than IPv4, meaning requests will always try IPv6 first then IPv4. It's caused a lot of real quirky ass issues, especially when I was using a 802.11g adapter years ago.
 

Skripka

[H]F Junkie
Joined
Feb 5, 2012
Messages
10,792
I'm guessing you already went through the adapter settings and made sure "Obtain IP address automatically" and "Obtain DNS automatically" is selected on the adapter?

Instructions:
http://windows7themes.net/en-us/how-to-enable-dhcp-in-windows-7/

Also would turn off IPv6. I've noticed more problems than not when having it on and not using IPv6. For whatever reason Microsoft thought it a brilliant move starting with Windows 7 to enabled IPv6 by default and assign it a higher priority than IPv4, meaning requests will always try IPv6 first then IPv4. It's caused a lot of real quirky ass issues, especially when I was using a 802.11g adapter years ago.
Corrected the above (both Obtain fields, and turning of IPv6)....Windows disabled DHCP on its own again within 24 hours. WTF?
 

felt

Limp Gawd
Joined
Dec 17, 2009
Messages
502
Have you tried deleting the driver and reinstalling? Like completely uninstall the driver and all traces of the driver
 

exchange keys

Limp Gawd
Joined
Feb 18, 2009
Messages
339
Anything in the Event Logs?

I'm wondering if the DHCP Client service in Windows Services is set to something other than the default settings (i.e., Automatic, Local Service).

If anything, are you able to just give yourself a static IP address on your WLAN network adapter, and match it on your home router? This might help you troubleshoot the "dhcp" issue.
 

Skripka

[H]F Junkie
Joined
Feb 5, 2012
Messages
10,792
I did some experimenting last few days:

Uninstalled and reinstalled drivers...no change.

What I also found...whenever my VPN tunnel would cut out, windows would reset not only my adapter DHCP settings but also my adapter DNS settings. That is apparently the trigger.
 
Top