Win 7 64bit .lnk issue after windows update

Pagan Wizard

2[H]4U
Joined
Jan 12, 2002
Messages
2,632
Like the headline reads, after I recently did Windows Update on my computer with Win7 64 bit, I now have the dreaded .lnk problem. I can revert to my last saved restore point, but when I power down, it wants to redo the updates causing the problem all over again. I watched 4 or 5 YouTube videos, and none of them had the cure. PLEASE HELP ME!!!
 

devman

2[H]4U
Joined
Dec 3, 2005
Messages
2,400
An explanation of the problem would be nice. What is the ".lnk problem"?
 

Pagan Wizard

2[H]4U
Joined
Jan 12, 2002
Messages
2,632
All icons on the desktop and in quick launch, are solid white boxes and inactive, they no longer launch the associated program.
 

evilsofa

[H]F Junkie
Joined
Jan 1, 2007
Messages
10,078
This page explains the problem and the reasons, and provides a link to a registry fix for Vista, which apparently works for Win7. This page has updated registry fixes for Win7 specifically, but I'm not sure what the difference is.

Edit: I think this is the manual fix to the registry if you don't trust registry fixes from the Internet:

From the affected machine, launch registry editor (regedit.exe) with your Admin Account
Navigate to below key and export to make a backup in C:\Apps (file:///C:/Apps)

HKEY_USERS\users key\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.lnk

Delete other key under .lnk, leaving OpenWithList and OpenWithProgids
Press F5 to refresh then close Registry Editor
Launch Task Manager > Processes and locate explorer.exe then right click and select End Process
Click on File > New Task (Run) and key-in explorer.exe and hit Enter
Test to confirm that issue should now be fix

(Source, down in the comments)
 

Pagan Wizard

2[H]4U
Joined
Jan 12, 2002
Messages
2,632
evilsofa, sorry I didn't check in to see your response sooner. I have been really busy with work and other things. I will try to resolve my computer issue ASAP and will respond here to let you know how things went. Thanks again!!!!!
 

Pagan Wizard

2[H]4U
Joined
Jan 12, 2002
Messages
2,632
evilsofa, I download the exe fix from that page, and nothing happened even after a restart. I then decided to go to Task Manager and manually force explorer.exe off then relaunched it.....voila........problem resolved. TYVM You were a huge help.
 
Top