WiFi disconnects and reconnects quickly

vietkangta

Limp Gawd
Joined
Dec 18, 2005
Messages
315
I am having this extremely weird issue

here is my home network setup. I have the att nvg589 modem/router combo. I had an ASUS ac68u wired into to my modem. the nvg589 WiFi radios are disabled so i can use the better WiFi radio from the ac68u. ASUS routers are set to access point

It has been working fine last 5 years. but lately i noticed that whenever i use my android phones to watch YouTube or TikTok, etc. i can see on the top right of my phones that the phone quickly disconnects and reconnects to the WiFi. We talking like 1 second here. This happens randomly. Could be 5 mins. could be 20 mins. Strangely. It only does this or i notice it doing this on my android phones. I also have an iPhone and laptop connected to the same WiFi that never shows this issue.

i have 3 different android phones and they all exhibit the same issue. Even on my brand new oneplus 8t! This is most noticeable in YouTube because you get the connection issue message also. So thinking it’s the router i went out to buy a new one and replaced it with the ASUS ax58u. Same problem. So i replaced my Ethernet cable connecting to the modem. Same issue. I moved the router to a different location. Same problem. I swapped the channels on my 5ghz line. Same issue.

So now i am stump. What could be the issue? I don’t see anything weird in the logs in my ASUS router or my att modem. And all firmwares are updated. And everything rebooted multiple times.

All my wired connections are fine like my desktop which shows no sign of disconnect. So i am baffled.
 
Last edited:

SamirD

2[H]4U
Joined
Mar 22, 2015
Messages
3,988
Sounds like they broke something in an Android update. You don't have any choice but to wait to see if something fixes it. Or you can change and play with your wifi settings until the problem goes away.
 

vietkangta

Limp Gawd
Joined
Dec 18, 2005
Messages
315
Sounds like they broke something in an Android update. You don't have any choice but to wait to see if something fixes it. Or you can change and play with your wifi settings until the problem goes away.

the weird part is all 3 of my android run different android os lol.
Even when I get the no internet message or see the icon disconnect and reconnect my internet is working fine since it happens so quickly.

I’ve Google so many hours and no one has had the same issue.
 

MrGuvernment

Fully [H]
Joined
Aug 3, 2004
Messages
19,769
Someone little wanna be wifi hacker in the area using Kali linux and dropping networks trying to scan / exploit them maybe.
 

SamirD

2[H]4U
Joined
Mar 22, 2015
Messages
3,988
the weird part is all 3 of my android run different android os lol.
Even when I get the no internet message or see the icon disconnect and reconnect my internet is working fine since it happens so quickly.

I’ve Google so many hours and no one has had the same issue.
Then it may actually be a glitch in the icon program versus a real issue. If there's a way to run a continuous ping or use packlosstest.com for a long enough duration, it would be interesting to see if there is any real packet/Internet loss.
 

scrappymouse

Limp Gawd
Joined
Mar 18, 2016
Messages
173
Android has had problems in the past with Wifi channel switching, try setting the option in your router to specific channel(preferably 6) as last time Android had issues with the other channels. Perhaps when your router switches channels it's screwing up Android somehow. Just something to try, may or may not be it.
 

vietkangta

Limp Gawd
Joined
Dec 18, 2005
Messages
315
Android has had problems in the past with Wifi channel switching, try setting the option in your router to specific channel(preferably 6) as last time Android had issues with the other channels. Perhaps when your router switches channels it's screwing up Android somehow. Just something to try, may or may not be it.

I have it set to a single channel and it still did it.
 
Top