Wifi card not initialized on 2 Lenovo Thinkcentre m720s. Dead pci-e slots or something else?


Feb 11, 2004
In the office we have two Lenovo m720s SFF machines. Recently purchased two AC-7260 AC1200 generic wifi x1 cards and when I plugged them in both machines failed to recognize them in Windows 11 device manager. Both times the cards were missing in action. The m720s has two x1 slots plus an x16 slot and I tried all of them. Not only that I tried an old Atheros Killer wifi card and an AX3000 wifi pci-e adapter. These cards were verified in other machines as working. Interestingly enough the Killer card had a NGFF m.2 card I could remove and able to install on the motherboard of the m720s where there was an m.2 ngff unoccupied slot available and that worked. So not a blacklist issue since if the Killer card was being blacklisted it wouldn’t have worked in the m.2 wifi slot. My best guess is that they sold me non- functional pci-e slots on both machines. Researching the issue showed that I am not the only one having the issue. Lenovo has a history of whitelisting so not sure whats going on in that could they whitelist what goes into the pci-e slot specifically but not the m.2 slot. Doesn’t make sense. In anycase not sure whats going on. If anyone can help or advise?

I checked. No options to anything like that though did find a whitelist in the bios code itself.
The card has no c-link cable requirement. The only thing you have is a usb motherboard header cable for bluetooth which is not necessary if all you want is wifi.
Tested 3 other cards in same fashion and they were all recognized with or without cables in another manufacturer machine think Dell. So pretty sure its a whitelist
issue. Thanks to Lenovo.