Why is Devices and Printers scan so d--- slow?

x509

2[H]4U
Joined
Sep 20, 2009
Messages
2,630
My system is a new laptop, running Win 10 Pro 64, fully patched up.

If I do a Devices and Printers scan, it takes like over a minute.:confused: :wtf: Do i need to change some config settings? o_O
 

bigdogchris

Fully [H]
Joined
Feb 19, 2008
Messages
18,462
When I open Devices and Printers I also notice it can go very slow. Sometimes it's not slow, but often it is.
 

BulletDust

Supreme [H]ardness
Joined
Feb 17, 2016
Messages
6,057
It's been that slow on every system I've ever worked on, including my own.
 

MGCJerry

Limp Gawd
Joined
Sep 18, 2005
Messages
143
Half the time my windows 7 box does that. Sometimes its fast, sometimes its slow. No idea why, I originally thought it was trying to communicate with the default printer and if it was "off" you'd have to wait for it to time-out. I have a network printer and its still sometimes slow to display which shot that theory.
 
D

Deleted member 245375

Guest
No issues here, of course I don't keep all the devices I have under that particular dialogue plugged in constantly (some I don't even own anymore so time to clean house I suppose). I just hit the Windows key, typed dev and selected Devices and Printers on the menu and it opened fully in about 1.2 seconds - if that's the kind of delay you're speaking of then it's not much at all but if you have the devices connected then I suppose it could take longer as it polls them for connectivity.
 

PliotronX

2[H]4U
Joined
Aug 8, 2000
Messages
2,070
Since it's Pro, you are able to access the printmanagement.msc snap-in. Try going in there and see if any "ghost printers" show up that do not in Devices & Printers. I worked on a 10 Home computer that had been upgraded from 8 and it literally took five minutes to load D&P and it had ghost entries of the printer that were conflicting yet we could not remove them. Since printmanagement.msc is not in the Home edition, we ended up reloading with 8.1 and it worked flawlessly after that.
 
  • Like
Reactions: x509
like this

Tawnos

2[H]4U
Joined
Sep 9, 2001
Messages
3,808
Any of your printers on the network? Are their drivers up to date? That might be an issue where the printer responds affirmatively to Device Stage support, but doesn't return correct info. Could also be a low power mode on a network printer, where its response time is slowed as it is queried & retried.
 
Top