What's with Nvidia's drivers these days?

Discussion in 'Video Cards' started by hedron, Apr 21, 2018.

  1. hedron

    hedron Limp Gawd

    Messages:
    495
    Joined:
    Apr 24, 2008
    Am I the only one who gets lock ups everytime they open the control panel? I've never ever encountered a problem with their drivers until about a year or two ago. I'm not an avid gamer, so I don't obsess much over drivers and you can see from my video card choice that it's not a critical component. But I do play an occasional game and I'd like to fool with the control panel, but it crashes intermittently. I'm just wondering if this is a know bug or issue? I never have issues while actually playing a game. I've been playing Formula 1 2016.

    Maybe it's bitcoin. Please say it's bitcoin, I need another reason to bash it. : P
     
  2. Nenu

    Nenu [H]ardened

    Messages:
    18,069
    Joined:
    Apr 28, 2007
    It helps to explain the issue better.
     
  3. Shadowed

    Shadowed Limp Gawd

    Messages:
    242
    Joined:
    Mar 21, 2018
    Are you on a hard drive?
     
  4. Decibel

    Decibel 2[H]4U

    Messages:
    3,790
    Joined:
    Nov 10, 2000
    I'm not running into the issue you've described. Time for a complete uninstall followed by a DDU run in safe mode and reinstall maybe?
     
    Armenius likes this.
  5. hedron

    hedron Limp Gawd

    Messages:
    495
    Joined:
    Apr 24, 2008
    I tried using some driver uninstaller I found on guru3d, but the problem remains. I think it's just taking up the same memory space as another application and there's nothing I can do about it.
     
  6. Shadowed

    Shadowed Limp Gawd

    Messages:
    242
    Joined:
    Mar 21, 2018
  7. pendragon1

    pendragon1 [H]ardForum Junkie

    Messages:
    12,353
    Joined:
    Oct 7, 2000
    never mind misread...
     
  8. misterbobby

    misterbobby 2[H]4U

    Messages:
    3,412
    Joined:
    Mar 18, 2014
    Armenius and Kwaz like this.
  9. pendragon1

    pendragon1 [H]ardForum Junkie

    Messages:
    12,353
    Joined:
    Oct 7, 2000
    Shadowed likes this.
  10. misterbobby

    misterbobby 2[H]4U

    Messages:
    3,412
    Joined:
    Mar 18, 2014
    oops...:facepalm:
     
    SvenBent, Sonicks and Shadowed like this.
  11. Shadowed

    Shadowed Limp Gawd

    Messages:
    242
    Joined:
    Mar 21, 2018
    Haha, I meant to ask OP if he used DDU or not!
     
    pendragon1 likes this.
  12. SvenBent

    SvenBent 2[H]4U

    Messages:
    2,252
    Joined:
    Sep 13, 2008
  13. Comixbooks

    Comixbooks Ignore Me

    Messages:
    11,514
    Joined:
    Jun 7, 2008
    Once I find a good set of drivers I stop upgrading unless it's required for a major release.
     
  14. {NG}Fidel

    {NG}Fidel Fear Monger

    Messages:
    6,470
    Joined:
    Jan 17, 2005
    Honestly I have been pretty annoyed that I am still having an issue in Senua Hell Blade and no driver version fixes it. System has no issue in any other game at all....
     
  15. _l_

    _l_ I Am A Cock

    Messages:
    1,178
    Joined:
    Nov 27, 2016
    with the last few releases of nVidia drivers I've experienced green flickering on the display when running Mass Effect Andromeda at 1920 x 1080p. Have to use Windowed without boarder to make it stop flashing. Then, with the most recent release, if you're in full screen mode you can't see the mouse pointer when you go to the map or any other such function(s) like weapons select, etc.

    yes, windowed mode solves it but really ...
     
    hedron likes this.
  16. Algrim

    Algrim [H]ard|Gawd

    Messages:
    1,205
    Joined:
    Jun 1, 2016
    I had this happen to me during one of the Windows Insider fast ring updates. It was related to the gaming mode, as far as I could tell.
     
    Armenius likes this.
  17. hedron

    hedron Limp Gawd

    Messages:
    495
    Joined:
    Apr 24, 2008
    Well, I'm pretty certain my card bit the dust, and I'm now using integrated graphics. My PC wouldn't boot this morning until I removed the vidya card.

    I'm pretty sure constant overheating did it? Even though I had tested it with furmark and it didn't seem like it was overheating. I had put an after market cooler on, and the fan has never turned on. But it worked, and as stated it didn't seem to be overheating. Oh well... I got a few good years out of it.

    Question: The adapter has three wires black, red, yellow, and blue. It's an Artic Cooling fan/heatsink. But the terminal/receptacle on the video card itself only has three ports. I had assumed that the fourth wire was just for reading the fan speed. But maybe the wires are mixed up? How would I resolve this issue if I bought a new GPU and used this same heatsink? I can only guess this issue would reproduce itself.
     
  18. Decibel

    Decibel 2[H]4U

    Messages:
    3,790
    Joined:
    Nov 10, 2000
  19. Archaea

    Archaea [H]ardForum Junkie

    Messages:
    8,502
    Joined:
    Oct 19, 2004
    If you hadn’t modded the card it’d likely still be working and you wouldn’t have made this thread because you likely wouldn’t have had the unique control panel lockup issue.

    Why do you want to break your new replacement card too?
     
    defaultluser likes this.
  20. hedron

    hedron Limp Gawd

    Messages:
    495
    Joined:
    Apr 24, 2008
    I've owned this card for like half a decade. The only thing that might have resulted in damage is the fact the fan never worked. But I watched the temps, and they were always within range, even during furmark. I've put aftermarket coolers on every single other card I've owned, and this is the only non-AMD card to bite the dust. How long do most people's cards last?

    I just tested the fan by plugging it in directly to a 12v power supply and it works fine. I don't know why the card itself won't turn it on. Either the power unit in the card isn't 12v or it's broken or the drivers just don't turn it on for some reason.
     
    Last edited: May 12, 2018