What is up with UEFI support with the Fury X?

Araxie

Supreme [H]ardness
Joined
Feb 11, 2013
Messages
6,452
it depends on the AIB really.. some cards support UEFI like the Asus, or Sapphire.. but UEFI isn't supported originally by the Reference AMD model. you can just download the Asus BIOS (here) and flash your card.
 

magictoaster

Limp Gawd
Joined
Apr 6, 2005
Messages
454
it depends on the AIB really.. some cards support UEFI like the Asus, or Sapphire.. but UEFI isn't supported originally by the Reference AMD model. you can just download the Asus BIOS (here) and flash your card.

I've contacted MSI and I'm waiting for an answer. If they do not reply I'll try the ASUS bios.
 

DedEmbryonicCe11

[H]ard|Gawd
Joined
Jun 6, 2006
Messages
1,589
it depends on the AIB really.. some cards support UEFI like the Asus, or Sapphire.. but UEFI isn't supported originally by the Reference AMD model. you can just download the Asus BIOS (here) and flash your card.
My Sapphire Fury X isn't showing UEFI enabled in GPU-Z. I've uploaded my BIOS but it's not in the database yet. It's a different version number than any other so far.
 

Araxie

Supreme [H]ardness
Joined
Feb 11, 2013
Messages
6,452
My Sapphire Fury X isn't showing UEFI enabled in GPU-Z. I've uploaded my BIOS but it's not in the database yet. It's a different version number than any other so far.

that's kinda weird you know.. and thanks I thought all Sapphire arrived with UEFI support, maybe yours is an early version?
 

magictoaster

Limp Gawd
Joined
Apr 6, 2005
Messages
454
Flashed my MSI Fury X with the Sapphire VBIOS (015.048.000.066.006043) available at Techpowerup. Secure Boot now works perfectly!
 
Last edited:

DedEmbryonicCe11

[H]ard|Gawd
Joined
Jun 6, 2006
Messages
1,589
that's kinda weird you know.. and thanks I thought all Sapphire arrived with UEFI support, maybe yours is an early version?
Yes my card was purchased October 17th and the BIOS currently available was uploaded November 4th. The actual compile dates are much older I guess that just shows you how long the boards were in the pipeline before becoming available for purchase due to component shortages.

I doubt there are any hardware differences, just an older BIOS. I definitely don't have any coil whine or pump noises. I really can't imagine that even though prior to the day I purchased every reasonably priced vendor had 0 stock that mine was sitting in a warehouse somewhere.

The uploaded version is from 113-C8800100-103 board ID and VER015.048.000.066.006043. Mine is 113-C8800100-102 board id and VER015.048.000.064.005990. It looks like when I have free time I will be flashing mine as well.
 
Top