Wake on LAN strange problem

britonk

n00b
Joined
Feb 25, 2007
Messages
40
I have a problem with Wake On LAN (WOL) and wonder if anyone can help?

First of all I'll explain the setup.

The PC I am trying to Wake uses a Gigabyte GA-890GPA-UD3H motherboard with an onboard network card which does support WOL.

It is connected to a CISCO WRT320N router which is in turn, of course, connected to the internet.

Power on by "PME" event is enabled in the BIOS. I can send a magic packet on the local network either from my laptop or my android phone (using an app called aWOL) and this does wake up the PC fine.

When I send a magic packet over the internet (via 3G) it does wake the PC if it's recently been turned off. For some reason if the PC has been switched off for a while the magic packet does not wake the PC.

The PC has not gone into a low power state because if I send a packet locally on the LAN it DOES still wake the PC. If I then shut it down and wake it up over the WAN it starts up fine.

If I send packets to the PC while I have wireshark monitoring port 9 it receives all packets (both local and over WAN) fine.

I can't understand why a packet send over the WAN won't wake the PC if it's been off for a while. Does this make sense to anyone out there? I can provide Wireshark captures if anyone needs to see them.

Thanks for any help.

Brian
 

britonk

n00b
Joined
Feb 25, 2007
Messages
40
Hi - thanks for your reply. The PC on the local network is on a fixed IP. Obviously my Internet address can change but hasn't since I set all this up as I have checked.

I haven't actually measured how long until it stops doing it as it's quite difficult to measure but I will give it a go.
 

britonk

n00b
Joined
Feb 25, 2007
Messages
40
Hi,

That's a good suggestion, thanks. I don't think this is what is happening though or otherwise the locally sent packets wouldn't wake the PC either?

Thanks,

Brian
 

vectravl400

Weaksauce
Joined
Sep 24, 2007
Messages
80
It seems like the router is the source of the problem. According to cisco (http://homecommunity.cisco.com/t5/Wireless-Routers/320N-Wake-On-Wan/m-p/297570) this isn't a supported feature for the 320n. So it looks like you have a couple of options:
  • Set the bios in the computer to wake up at a specific time and adjust the power setting so it won't go to sleep
  • Flash the router with the ddwrt firmware (check to make sure it's compatible first) as this does appear to support the Wake on Wan function
 
Top