Vista 64, programs won't install?

Kevin5255

Limp Gawd
Joined
Feb 14, 2006
Messages
393
I've been trying to get Urban Terror to install on my computer, it's an old quake mod that is now a free-to-play standalone client. But whenever I double click on the icon on my desktop to begin the install, i see my hard drive light go on but nothing happens except my mouse has the loading symbol on it and my desktop is frozen. I can move my mouse around, but can't manipulate icons or anything. what is going on?

also, I downloaded SP1 last night, but I'm still on the fence on whether i should install it or not. Is it a good idea to install?
 
Your thread title is very misleading. You mean that one old program won't install?. Quite possible it doesn't like Vista and/or a different Program directory structure. Have you tried installing as Admin?

Yes SP1 is well worth installing.
 
Yes, install SP1, as far as urban terror, haven't tried it but the download page did say 'try installing to somewhere other than \program files if you run Vista' did you try that?
 
Yes, install SP1, as far as urban terror, haven't tried it but the download page did say 'try installing to somewhere other than \program files if you run Vista' did you try that?

I read that too. The problem is that it won't even open a program. No new windows come up what I double click. It says the process is still running in the task manager though.
 
Try XP compatibility, and/or run as admin, maybe? Is urban terror still supported? If so, might want to ask on their forums as I don't know if many people here have played it.
 
Back
Top