Updating Omnios from r151024 to r151026

Discussion in 'SSDs & Data Storage' started by N Bates, May 13, 2018.

  1. N Bates

    N Bates [H]Lite

    Messages:
    71
    Joined:
    Jul 15, 2017
    I wonder if anyone encountered anything like this issue, I am trying to update from Omniosce from r151024 to r151026 and have the below error:

    when I enter pkg unset-publisher omnios, I get the below

    pkg unset-publisher removal failed for 'omnios'Unknow publisher

    and when I input:

    pkg set-publisher -g https://pkg.omniosce.org/r151026/core omnios, I get the below:

    pkg set-publisher: the origin URI's for 'omnios'do not appear to be valid pkg repository, please verify the repository location and the client network

    Unable to contact valid package repository
    encountered the following error (s):
    unable to contact any configured publisher.
    this is likely a network configuration problem.
    Framework error: code: E_COULDNT_CONNECT (7)
    URL: 'https://pkg.omniosce.org/r151026/core' (happened 4 times)

    I can ping my PC from the server and vis versa can ping te server from the PC.
    Not sure how to rectify the error and upgrade, I was contemplating a re-install, but this is so painful.

    Could this also be related to not being able to see the NAS from any other PC or device in my network, unless I type phisically the addrss.

    Thanks ever so much for all your help.
     
  2. jad0083

    jad0083 Limp Gawd

    Messages:
    130
    Joined:
    Apr 30, 2006
    check gateway config via 'netstat -rn -finet'
    if not setup properly, config via: 'route -p add default <router ip>'

    clso make sure to properly setup DNS via:

    echo 'nameserver <DNS server IP>' >> /etc/resolv.conf
    cp /etc/nsswitch.conf{,.bak}
    cp /etc/nsswitch.{dns,conf}
     
  3. N Bates

    N Bates [H]Lite

    Messages:
    71
    Joined:
    Jul 15, 2017
    after executing the first cli I got the below, how do I remove the 192.168.1.0, this is not my router address

    root@NAS:~# netstat -rn -finet

    Routing Table: IPv4
    Destination Gateway Flags Ref Use Interface
    -------------------- -------------------- ----- ----- ---------- ---------
    127.0.0.1 127.0.0.1 UH 6 44 lo0
    192.168.1.0 192.168.1.13 U 4 31 nge0
    root@NAS:~# route -p add default 192.168.1.1
    add net default: gateway 192.168.1.1
    add persistent net default: gateway 192.168.1.1
    root@NAS:~# netstat -rn -finet

    Routing Table: IPv4
    Destination Gateway Flags Ref Use Interface
    -------------------- -------------------- ----- ----- ---------- ---------
    default 192.168.1.1 UG 1 0
    127.0.0.1 127.0.0.1 UH 6 44 lo0
    192.168.1.0 192.168.1.13 U 4 142 nge0

    Many thanks.
     
  4. jad0083

    jad0083 Limp Gawd

    Messages:
    130
    Joined:
    Apr 30, 2006
    that's fine, that's your broadcast address. Have you done the second part of the scripts? what happens when you do 'cat /etc/resolv.conf'? for testing purposes, try using Google's DNS server '8.8.8.8', then try 'nslookup pkg.omniosce.org' and see if you get something
     
  5. N Bates

    N Bates [H]Lite

    Messages:
    71
    Joined:
    Jul 15, 2017
    I haven't done the second part yet, well I tried but it was late so I left it, I am going to try it now and report back, I am curreently using DNS Servers 8.8.8.8 and 8.8.4.4.
     
  6. N Bates

    N Bates [H]Lite

    Messages:
    71
    Joined:
    Jul 15, 2017
    Hopefully you can make some sence out of the below, I have edited the /etc/resolv.conf file and added nameserver 192.168.1.1 and nameserver 8.8.4.4, but it looks like the connection to the server timed out when I have tried the nslookup pkg.omniosce.org.

    OmniOS 5.11 omnios-r151024-e482f10563 January 2018
    root@NAS:~# cat/etc/resolv.conf
    -bash: cat/etc/resolv.conf: No such file or directory
    root@NAS:~# cat/etc/resolv.conf?
    -bash: cat/etc/resolv.conf?: No such file or directory
    root@NAS:~# cat /etc/resolv.conf
    nameserver 192.168.1.1
    nameserver <DNS server IP>
    nameserver <DNS server IP>
    nameserver DNS 192.168.1.1
    root@NAS:~# echo nameserver 8.8.8.8 >> etc/resolve.conf
    -bash: etc/resolve.conf: No such file or directory
    root@NAS:~# echo nameserver 8.8.8.8 > /etc/resolv.conf
    root@NAS:~# cp /etc/nsswitch.conf{,.bak}
    root@NAS:~# cp /etc/nsswitch.{dns,conf}
    root@NAS:~# cat /etc/resolv.conf
    nameserver 192.168.1.1
    nameserver 8.8.8.8
    nameserver 8.8.4.4
    root@NAS:~# nslookup pkg.omniosce.org
    ;; connection timed out; no servers could be reached

    I will reboot and try again to access pkg.omniosce.org and see what I will get.
     
  7. N Bates

    N Bates [H]Lite

    Messages:
    71
    Joined:
    Jul 15, 2017
    The below is what I am getting after a reboot, is this how it should look, I will try upodating omnios now and see whether this will work.

    OmniOS 5.11 omnios-r151024-e482f10563 January 2018
    root@NAS:~# nslookup pkg.omniosce.org
    Server: 192.168.1.1
    Address: 192.168.1.1#53

    Non-authoritative answer:
    pkg.omniosce.org canonical name = omniosce.org.
    Name: omniosce.org
    Address: 129.132.2.8

    Briliant! after a reboot it worked and updated sucessfully:

    OmniOS 5.11 omnios-r151026-673c59f55d May 2018
    root@NAS:~#

    Thank you ever so much for all your help.


    The only thing I need to sort now is: the NAS server not showing up under any other machines under network, this is bugging me and I have been trying to resolve the issue for a few days now, I can not mount the NAS server on the Nvidia Shield 2017 as the server is not broadcasting properly, I can access it however in windows via the IP address but this will not work on the shield.
     
  8. jad0083

    jad0083 Limp Gawd

    Messages:
    130
    Joined:
    Apr 30, 2006
    Ok cool. is your nvidia shield on the same 192.168.1.x network? On your nvidia shield, have you also tried just the IP of your NAS? Also, make sure that NFS is turned on, on the shares themselves (especially if you're working with non-windows clients). By default, only smb/cfs is enabled when the share is initially created (that's why your windows box is able to see it immediately), so make sure nfs is as well.
     
  9. N Bates

    N Bates [H]Lite

    Messages:
    71
    Joined:
    Jul 15, 2017
    The Nvidia Shield is on the same network via DHCP on 192.168.1.., I have tried the below on the Nvidia:

    \\smb\192.168.1...\share_folder
    \\192.168.1...\share_folder

    none work though, NFS is turned on in omnios, I can see it via Napp-it in ZFS Systems, I think the Nvidia Shield only support SMB V1.0 though, none of my windows 10 machines see the NAS server directly under network but can be accessed via IP.