Unwanted Folders show up on Desktop but not in Desktop Folder Windows 10

biggles

[H]ard|Gawd
Joined
Jul 25, 2005
Messages
2,027
I am having a strange problem. 5 folders, including Program Files and Program Files (x86), are showing up on the desktop. These are the only 5 folders stored on the hard drive labeled E:. In other words, these are all the folders contained on my data drive (non-system drive). They are not shown as shortcuts to the folders but rather appear just like the normal folders. How can I remove these from the desktop without deleting the actual files? Also strange is that when I open the desktop folder with file explorer it says this folder is empty.
 

jmilcher

Supreme [H]ardness
Joined
Feb 3, 2008
Messages
4,795
So you have system folders that are essential to windows functionality, store on a separate drive?
 

AltTabbins

Fully [H]
Joined
Jul 29, 2005
Messages
20,147
Generally, this happens when you use the desktop for an installation. The installer assumes its at the root of the OS drive, looks for a program files folder, sees there isn't one, so it creates one for you. The best way to fix it is to just uninstall the program you installed to your desktop folder and leave the install settings stock. This drives me nuts and you would be surprised at which programs still do this. Origin comes to mind. If I install it to a secondary drive, it adds a program files folder to it no matter what settings you change during installation.
 
Top