Unknown Device in Device Manager

Discussion in 'Operating Systems' started by Nocontact, Jul 19, 2005.

  1. Nocontact

    Nocontact [H]Lite

    Messages:
    107
    Joined:
    Sep 8, 2004
    I just did a clean install of XP Home in a friends PC which has an Asus P4S800 mobo and a via firewire card. I'm assuming that one of the 2 'unknown device' exclamations that I'm finding in device manager is referring to this. He didn't get any discs with the card as it came installed and I'm at a loss to find them anywhere. I can't get windows to find it either so I'm not sure what to do.
    Any ideas what to do or how to determine for certain what these 'Unknown Device' listings refer to?
     
  2. Phaedrus

    Phaedrus [H]ard|Gawd

    Messages:
    1,126
    Joined:
    Nov 1, 2000
    you can go to the asus website and download any drivers available for your motherboard and install them.
     
  3. Nocontact

    Nocontact [H]Lite

    Messages:
    107
    Joined:
    Sep 8, 2004
    I did but I can't find any firewire drivers on the asus page and there's nothing on the disc it came with.
     
  4. Nasty_Savage

    Nasty_Savage [H]eathen Taste Righteous Fire!

    Messages:
    13,216
    Joined:
    Mar 19, 2001
  5. Ranma_Sao

    Ranma_Sao 2[H]4U

    Messages:
    2,577
    Joined:
    Mar 15, 2002
    Or look at the PNPID and then from there figure out what device it is. (Google is your friend)
     
  6. Nocontact

    Nocontact [H]Lite

    Messages:
    107
    Joined:
    Sep 8, 2004
    I'm stoopid. Turns out it was just the video card drivers which needed to be updated to enable dual monitors. Thanks for the suggestions.