Unable to share files with 2 routers


Oct 25, 2004
Ok, this is like a stubborn nut to me. I've setup a home network with 2 routers. My computer which im using right now is connected to Router 1 and where the modem is connected as well as the Router 2 (duh! :) ). I've disabled the DHCP Server on Router 2 so I have no problem accessing the net on the computers connected to it. However, i'm unable to access/see the shared folders in those computers connected to Router 2.

List that i've tried:

  • Same Domain on all computers - OK
  • Used the Home Network Setup tool on 'My Network Neighborhood' - Same result, can't share anything.
  • Unblocked the firewall to allow the specific IP's on all computers to see each other.

Any suggestions on what else should be done? I'm using Windows XP in all computers if that helps.

Thanks in advance.


Limp Gawd
Feb 14, 2005
Do you have Norton/anything software firewalling your ports on the computers or one of them... or do you have firewalls on the routers that are running into each other and not leting ports throughput. Have a question? WHY are you using two routers? just try it with one. and do you have SP2 that will help and try configure out your Home Network Setup more... there are lots of options...GOOD LUCK


Limp Gawd
Feb 9, 2005
Windows default filesharing uses broadcasts to index computers on the local subnet and add to My Network Places. Routers segment broadcast domains, so the local SMB broadcast messages are not getting sent past the routers.

Instead, from a pc behind Router #2, try opening a network share on a computer connected to router 1 via IP address, as in "\\". An IP address is routable, a netbios name like \\homecomputer is not (unless explicitly mapped to IP using WINS or lmhosts).

Secondly, DHCP has nothing to do with it. If you are truly daisy-chaining routers, the DHCP follows the same rule. DHCP broadcasts won't propogate across routers, unless specifically configured to do so (which most home routers aren't going to support). It won't give addresses out the WAN ports, only LAN ports.