unable to set memory and fan speed for GPU2

Orddie

2[H]4U
Joined
Dec 20, 2010
Messages
3,146
Hi All!

Wanted to see if anyone else has run into this issue before.

Using Ubuntu 16.4, I installed version nvidia-387 and Cuda 9.1

my start.bash has
Code:
sudo nvidia-settings -c :0 -a [gpu:2]/GPUMemoryTransferRateOffset[3]=525
sudo nvidia-settings -c :0 -a [gpu:2]/GPUGraphicsClockOffset[3]=150
sudo nvidia-settings -c :0 -a [gpu:2]/GPUFanControlState=1
sudo nvidia-settings -c :0 -a [fan:2]/GPUTargetFanSpeed=95

when I issue nvidia-smi you can see the GPU 2 not honoring the settings
Code:
Sun Dec 17 11:41:39 2017       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 387.26                 Driver Version: 387.26                    |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 106...  On   | 00000000:01:00.0 Off |                  N/A |
| 95%   52C    P2    71W /  73W |   2429MiB /  3013MiB |    100%      Default |
+-------------------------------+----------------------+----------------------+
|   1  GeForce GTX 106...  On   | 00000000:02:00.0 Off |                  N/A |
| 95%   46C    P2    72W /  73W |   2429MiB /  3013MiB |     98%      Default |
+-------------------------------+----------------------+----------------------+
|   2  GeForce GTX 106...  On   | 00000000:03:00.0 Off |                  N/A |
| 62%   53C    P2    72W /  73W |   2423MiB /  3013MiB |     99%      Default |
+-------------------------------+----------------------+----------------------+
|   3  GeForce GTX 106...  On   | 00000000:05:00.0 Off |                  N/A |
| 95%   52C    P2    72W /  73W |   2429MiB /  3013MiB |    100%      Default |
+-------------------------------+----------------------+----------------------+
|   4  GeForce GTX 106...  On   | 00000000:08:00.0 Off |                  N/A |
| 95%   55C    P2    73W /  73W |   2429MiB /  3013MiB |    100%      Default |
+-------------------------------+----------------------+----------------------+
|   5  GeForce GTX 106...  On   | 00000000:0A:00.0 Off |                  N/A |
| 95%   50C    P2    72W /  73W |   2429MiB /  3013MiB |    100%      Default |
+-------------------------------+----------------------+----------------------+
|   6  GeForce GTX 106...  On   | 00000000:0C:00.0 Off |                  N/A |
| 95%   50C    P2    73W /  73W |   2429MiB /  3013MiB |    100%      Default |
+-------------------------------+----------------------+----------------------+
|   7  GeForce GTX 106...  On   | 00000000:0D:00.0 Off |                  N/A |
| 95%   51C    P2    74W /  73W |   2429MiB /  3013MiB |     99%      Default |
+-------------------------------+----------------------+----------------------+
                                                                              
+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|    0       824      G   /usr/lib/xorg/Xorg                             5MiB |
|    0      1320      C   ./ethdcrminer64                             2403MiB |
|    1       824      G   /usr/lib/xorg/Xorg                             5MiB |
|    1      1320      C   ./ethdcrminer64                             2403MiB |
|    2      1320      C   ./ethdcrminer64                             2403MiB |
|    3       824      G   /usr/lib/xorg/Xorg                             5MiB |
|    3      1320      C   ./ethdcrminer64                             2403MiB |
|    4       824      G   /usr/lib/xorg/Xorg                             5MiB |
|    4      1320      C   ./ethdcrminer64                             2403MiB |
|    5       824      G   /usr/lib/xorg/Xorg                             5MiB |
|    5      1320      C   ./ethdcrminer64                             2403MiB |
|    6       824      G   /usr/lib/xorg/Xorg                             5MiB |
|    6      1320      C   ./ethdcrminer64                             2403MiB |
|    7       824      G   /usr/lib/xorg/Xorg                             5MiB |
|    7      1320      C   ./ethdcrminer64                             2403MiB |
+-----------------------------------------------------------------------------+

but everyone else in the system is honoring the commands.

does anyone have a suggestion on how to fix?
 

Orddie

2[H]4U
Joined
Dec 20, 2010
Messages
3,146
figured it out...

I issued
Code:
sudo nvidia-xconfig -a --allow-empty-initial-configuration --cool-bits=28 --use-display-device="DFP-0" --connected-monitor="DFP-0" --custom-edid="DFP-0:/etc/X11/dfp-edid.bin" --enable-all-gpus
 
Top