suddenly artifacts in all games

Joined
Mar 15, 2002
Messages
782
I've had this ATI 9800 Pro (AGP) since a month after it was initially released. The card has done well for me for quite a while now.

Today sometime I decided to reinstall Battlefield 2 Special Forces expansion pack. Ive had vanilla Battlefield 2 installed on this box for several months now and was wanting to play the special forces maps since I've grown bored of Sharqi, Karkland, Jala, and etc.

Well, after installing Special Forces again I fired it up and noticed major artifacts. This is a new issue to me with this box. The games are still playable, but I don't want to game with tearing and "sparklies" popping up everywhre. I've never had any gaming issues since I've built this PC a couple of years ago. I rebooted and the problem still was there. So, i did what any self respecting geek would and reinstalled Battlefield 2 and Special forces and then of course patched to 1.4. This didn't fix anything.

I decided to test to see if it was just a Battlefield 2 problem and fired up Half Life 2 episode one since the Half Life stuff always runs like butter in my experience. Well,,,,I had artifacts there too. I even get artifacts in Google Earth now.

Is the ATI card dieing or does this point to a software issue. I haven't tried reinstalling drivers or DirectX yet. I'm running catalyst 8.263

UPDATE: I just uninstalled the ATI drivers and pulled the latest version off from ATI's site. The problem with artifacts still remains. Any advice or insight?
 

micron

Limp Gawd
Joined
Jun 13, 2004
Messages
193
I had a 9800 that artifacted because of a weak PS unit, but that probably isnt your problem.

I would remove the HSF(after making sure that it was working properly), and re-apply the thermal goop under it. If your problem still persists, then buy a new card. The 9800 series cards dont always have a long lifespan, and people here will attest to that.
 

Xiro

Weaksauce
Joined
Dec 1, 2005
Messages
105
aZn_plyR said:
is it only BF2?

vv

Private Citizen said:
I decided to test to see if it was just a Battlefield 2 problem and fired up Half Life 2 episode one since the Half Life stuff always runs like butter in my experience. Well,,,,I had artifacts there too. I even get artifacts in Google Earth now.

:)

Sounds like the 9800 is on it's last leg :(
 

Silus

Supreme [H]ardness
Joined
Aug 21, 2006
Messages
6,477
Private Citizen said:
I've had this ATI 9800 Pro (AGP) since a month after it was initially released. The card has done well for me for quite a while now.

Today sometime I decided to reinstall Battlefield 2 Special Forces expansion pack. Ive had vanilla Battlefield 2 installed on this box for several months now and was wanting to play the special forces maps since I've grown bored of Sharqi, Karkland, Jala, and etc.

Well, after installing Special Forces again I fired it up and noticed major artifacts. This is a new issue to me with this box. The games are still playable, but I don't want to game with tearing and "sparklies" popping up everywhre. I've never had any gaming issues since I've built this PC a couple of years ago. I rebooted and the problem still was there. So, i did what any self respecting geek would and reinstalled Battlefield 2 and Special forces and then of course patched to 1.4. This didn't fix anything.

I decided to test to see if it was just a Battlefield 2 problem and fired up Half Life 2 episode one since the Half Life stuff always runs like butter in my experience. Well,,,,I had artifacts there too. I even get artifacts in Google Earth now.

Is the ATI card dieing or does this point to a software issue. I haven't tried reinstalling drivers or DirectX yet. I'm running catalyst 8.263

UPDATE: I just uninstalled the ATI drivers and pulled the latest version off from ATI's site. The problem with artifacts still remains. Any advice or insight?

As Xiro pointed out, it seems your card is on its last leg. From what you told us, it really doesn't seem to be a problem, other than the card itself.
 

digital_exhaust

[H]ard|DCer of the Month - May 2008
Joined
Aug 14, 2006
Messages
6,903
I did that (Thermalright V1) and it did nothing to help, maybe I was too late. It started on a Sunday, and by Monday my card was charcoal.
 
Joined
Mar 15, 2002
Messages
782
Jeeze. Just what I needed. Sounds like the 9800 is dying a slow death. I don't ahve any spare parts laying around, so I cannot try a larger cooler without droping some cash. With DX10 games right around the corner, I'm gonna have to carefully decide how I want to upgrade. I would doubt Nvidia or ATI would put out a DX10 card with an AGP interface. JMO of course.

To be quite honest, money is an issue. Seems like I only work to pay bills anymore. I did a quick shopping list on newegg and came up with a conroe system, and a 6800GT PCIe, 2 gig of DDR2, Gigabyte mobo for just over 600 bucks. I selected the 6800GT because of its 100 dollar price tag. I didn't see any sense in dropping over 200 dollars on a vid card I would replace when DX10 games came out.

Anyone use newegg's financing? Anyone with any experiences with that?
 

HellMaX

Weaksauce
Joined
Jun 8, 2005
Messages
86
Same thing happened with my X800 XL, it got overheated and I was getting artifacts even on the post screen!

Now the weird thing is that after 4 days everything went back to normal. No artifacts to be seen anywhere, and i was able to play game with full graphics (of course I put a big fan on my case to avoid overheat again).

Of course it was too late, I had already brought a whole new computer with a X1900 XT :p
 

WarMace

Gawd
Joined
Aug 25, 2004
Messages
963
Is there no program that checks the whole video card for problems?

This same thing is happening to me as well. What really irritates me is only games with high details cause it to artifact like HL2 and BF2142, yet the HL2 benchmarks and 3DMark '05 and '06 run fine. And ATITool finds no issues.

New heatsink - no change other than a 25c drop in temp
Overclocking - no change
Underclocking -no change
DrivercleanerPro and catalyst6-5 - no change


Hell, even Vistas UAC is artifacting. :(
Im in the same boat as the above poster, trying to hold out till DX10 before upgrading.
 
Top