Streaming issue...

Ashton

2[H]4U
Joined
Nov 13, 2004
Messages
2,493
I've been troubleshooting this for weeks and cant figure out the problem...

I have 2 different media servers for streaming (Plex and Air Video) and I've always been able to stream SD content from home with minimal buffering... (Specs are the desktop in my sig)

But lately, It's been "play 30 seconds buffer 15 seconds" or at one point "play 10 seconds buffer 30" and this was on HVGA VIDEO (yes 320x240)

I cant figure out what happened... I first thought it was my cell, because it fluctuates in data speeds, but last week I went someplace that was covered by LTE and was pulling close to 20mbps down and around 5mbps up... I could go to websites and stream 720p content with only a second or two of buffering... but when I tried to connect to my home server, I got the same crap I mentioned before...

So, I thought "maybe my home upload connection is slowing down" (because my ISP is caring less and less about customer service... literally this PoS goes down at least once per day for anywhere from 2 minutes to an hour --- they know there's no real alternative here) but test after test keeps showing the same speed I've always had:
http://www.speedtest.net/result/2584328493.png
(~3mbps down, ~500kbps up)

So I ran internal tests and prolonged tests, tests where the data was isolated on an otherwise completely unused HDD to rule out seek times from other process threads... So far everything still says "this should work perfectly"

So I'm finally at my wit's end... Normally I'd just say "screw this" and upload all my content to my mobile device and take it with me... but... I bought my iPad thinking "I dont need much space - I can stream!" so there's hardly any room on it for videos... (In this pinch I'm starting to see the allure of Android and it's Micro-SDHC cards again... even if a lot of the other features leave me high and dry...)

Short version:
Cant stream without massive buffering, no apparent changes in bandwidth on either end. Using Plex/AirVideo. Any Ideas whats wrong?
 
Top