Strange specific graphic issue with my 970

Syribo

[H]ard|Gawd
Joined
Mar 9, 2008
Messages
1,515
So I'm having a strange issue. I am pretty sure this began since I swapped my 650 ti boost SC for my 970 GTX, I don't think I noticed this before. I also updated my Nvidia driver the day I got my 970.

So.. I am ONLY having a graphic issue in one game, FFXIV: A Realm Reborn. The other games I've played the last few days are fine (Diablo 3, ArcheAge, Terraria [Obviously not a graphic intensive game anyway]). 3DMark Firestrike ran fine, Nvidia's A New Dawn Demo, also perfectly fine. But here's what's happening..

So in certain areas, I am getting this weird graphic issue. It only happens when I'm REALLY high up, looking down and there's clouds or fog on the ground. I've only found 3 spots in game where it happens. Here's what it looks like:

W7fY0BA.png

HgoTwGu.png

2wg5KN4.png


I really hope it's not my card :( Also, it's at stock. I had overclocked it, but turned it down and it's back at stock now. My temps are fine, they're in the 30C's, I tried the newest driver, and now the one before this one, and it's still doing it in FFXIV.

God I hope it's not my card... What do you think? I also sold my 650 Ti to buy a second 27" monitor, so now if something happens to this one.. I'm stuck going back to my old 8800GTS in the meantime lol.
 

Syribo

[H]ard|Gawd
Joined
Mar 9, 2008
Messages
1,515
Oh wow! Thank you so much for that. I was going to Google to see if anyone had the same issue with the new 900 series cards, but for some reason I doubted anyone else would.

This makes me feel SO much better though. Was starting to freak out it was the GPU!
 
Joined
Nov 11, 2008
Messages
831
You're welcome!

Initially I thought it was the Gpu as well, maybe not making contact but with temps and other games fine I'm glad it wasn't. Heh that would bug me too. Glad I'm not playing FF14 :D
 
Top