Strange Netflix black screen


Mar 3, 2013
tl;dr :
I get black screen when i play video on the netflix app from windows 10. The video is fine on my laptop but its when the laptop is connected to TV via HDMI and want to play a netflix video on the TV i get black screen with the menu, audio and subtitle still working fine. But when i drag netflix app back to the laptop the video is back again. No error code either. What is also interesting is that this got worse after windows 10 update but i dont want to roll back just yet. I contacted netflix support and they told me buy a new hdmi cable 2.0 , which was wrong.

Any idea on how to fix or troubleshoot this further ? Im running out of idea now.
More details:

This video explains the issue only that is happning on my tv not laptop

I tried this these things so far, which did not work :

- Tried all different display modes, "show only screen 2" " extended display" etc
- Re-installed Netflix from Windows store.
- A new 4k HDMI cable to make sure HDCP handshake is okay.
- Installed newest and old nvidia video driver.
- Connected laptop to another TV, still black screen.
- Microsoft Edge browser

The only way i can watch Netflix now on my TV using the laptop is using Chrome or Firefox which has horrible quality, MS Edge doesn't work either. I updated windows 10 just couple days so i also suspect that may a reason but i used to get black screen sometimes before that too, but it used to work again after restarting the pc another day. But now nothing seems to work.

Only thing i can think of now is too reinstall windows or roll back on windows updates .


Oct 9, 2003
My suggestion is always to reinstall. Once you've got the hardware key from microsoft for your win10 upgrade, you can clean install win10 and the key will just reinstall itself. Most likely it's some obsolete driver that didn't disable properly during the upgrade. I upgraded 5 systems to win10, and it was only a laptop that had issues, and needed a reinstall from scratch to clean it up.


Jul 25, 2001
Yeah what the last two posts said, sounds like an HDCP issue. If you're running an Nvidia card you can pull up the Nvidia control panel and check HDCp status to the display.