So... Rome: Total War, looking for some help.


Jan 31, 2009
Since this game is getting a little dated I decided to post my cry for help here... Hopefully someone has an easy fix?

The problem is as follows. I have the discs for Rome: Total War and installed the game onto my PC without a problem. However, when I start the game the copyright screen (with the hoplites in the background) displays as normal but then the game minimizes itself and closes.

I tinkered with the compatibility options and did not have any luck, the same thing would keep happening.

Next, I installed the Barbarian Invasion expansion, and that game, too, does the same thing. Minimizes and closes.

I then decided to patch the game... And I can't find the things anywhere! Not on the Total War site, not on Sega's support site, strategy informer (has them, BUT, the link leads to some weird pdf viewer download?), so... I believe I'm stuck.

Any help would be appreciated. =) My specs are in my sig...
Thanks for the response!

Either way, I downloaded each of the patches and installed them one after the other, starting with version 1.2... Then 1.3, and finally 1.5.

After each installing I attempted to start the game, but the same thing I mentioned in the previous post continued to happen. The copyright screen opens up, then the game minimizes into the task bar.

I've tried maximizing the game, but it simply minimizes once again.

I have also tried a combination of running the game with XP Service Pack 3 compatibility and XP Service Pack 2, and running the game as an administrator.

As is, I do not know what other steps to take in attempting to remedy this problem. I have been to the Total War forums and there are players who are able to run the game without any problems, both that use Steam and those that do not.

I suppose I 'could' buy the Steam version of the game, but I don't wanna blow $10 on a game that I already own and have been able to play (up until using Windows 7).

Any thoughts?
You said you tried compatibility options, so you did try disabling both visual themes and desktop composition? Along with the obvious of XP mode and running as administrator.
Well, should you decide to grab it off Steam, it does work perfectly and with no tweaking.
Thanks for the link Tark, buuuut... I believe that Microsoft is wrong~

Blade - Well! I thought that I looked through the whole menu with the compatibilities, but I did overlook the desktop composition, somehow. Either way, I checked that and started Rome and it played pretty flawlessly.

Reus - I shall save my ten dollars!

Thanks for your replies guys, figures that I overlook something and once tat's found the game works, but! All is well.
I checked the 'Disable desktop composition' box in the compatibility tab and... Apparently that's all it took, I've been playing the game for hours without any trouble.
If you like Rome, try Empire and Napoleon, they are outstanding! I cannot wait for Shogun II.