slow performance windows message

fightingfi

2[H]4U
Joined
Oct 9, 2008
Messages
3,231
i keep getting this on my system at times while playing MS flight sim x and arma 3

Change the color scheme to improve Performance

I thought my specs were good enough for this not to happen whats your take \ opinion\ help

I7 4790k stock
16 gigs of ram ddr3 1600 stock
240 C: drive ssd OCZ brand
amd r9 390 16.2 drivers installed
gigabyte z87x-udh4 board
Windows 7 Ultimate 64 bit sp1
4tb back up hdd for steam\games\etc..
 

atom

Gawd
Joined
May 3, 2005
Messages
851
Its that non X edition video card. Since I don't game that often anymore I will trade you my 280x for that non x 390. PM me if you're interested.
 

John721

[H]ard|Gawd
Joined
Mar 8, 2006
Messages
1,623
Do you have a multimonitor setup or otherwise have the iGPU enabled?
 

Armenius

Extremely [H]
Joined
Jan 28, 2014
Messages
35,428
It's nothing wrong with your hardware, it's the game. It might be cutting into the DirectDraw performance on your desktop and Windows thinks there is something wrong. Just ignore it because it shouldn't be affecting the game's performance. I've gotten these messages before in Windows 7 in a variety of games with a single GTX 780, SLI GTX 780, and SLI GTX 970.
 
  • Like
Reactions: DF-1
like this

qbanb8582

2[H]4U
Joined
Sep 15, 2006
Messages
2,063
Try this on the shortcut.

414x565ximage48.png.pagespeed.gp+jp+jw+pj+js+rj+rp+rw+ri+cp+md.ic.GKLwzO-oUn.png
 

Sikkyu

I Question Reality
Joined
Jan 21, 2010
Messages
2,878
my buddy had this. he had only 8 gb of ram running win 10, and his shit would constantly crash after he upgraded to from win 7.

I bugged him about it everytime he would crash out of a game until he finally got 8 more gb of ram and now he doesn't get that message or crash.
 

madFive

metal[H]ead
Joined
Mar 26, 2008
Messages
9,387
Just check the "do not show this message again" box. Problem solved!
 

madFive

metal[H]ead
Joined
Mar 26, 2008
Messages
9,387
apparently win 10 will ignore your "check to ignore" after a time, so it will still be a problem.

Of course. I have yet to see that message in Win10, but no surprise it continues to ignore the wishes of the user in general. :shifty:
 

rezerekted

2[H]4U
Joined
Apr 6, 2015
Messages
3,043
Win7 sometimes does that when Aero is enabled, no matter how good your hardware is. I read recently there is a way to disable that message completely but can't remember how to do it now. I use Win8.1 so never get that issue because no Aero.
 

MavericK

Zero Cool
Joined
Sep 2, 2004
Messages
31,594
Options are basically:

1. Get more RAM
2. Increase / enable page file
3. Decrease Aero features

For me, I was getting issues with the latest Ubisoft games (RB6: Siege, The Division) running out of memory. Had to re-enable my page file for them to work properly. No other games had this issue so I'm not sure why Ubi games are coded so shittily.
 

Spidey329

[H]F Junkie
Joined
Dec 15, 2003
Messages
8,683
I used to get that in Battlefield 4 all the time. There's a setting somewhere, but it doesn't stick as well as it should.
 

LeviathanZERO

Supreme [H]ardness
Joined
Dec 20, 2003
Messages
6,496
Happens in Win 7 too.
Supposedly you go into the Action Center> Change Action Center settings> Disable Maintenance messages for Windows Troubleshooting.

At least that is what I have found scouring the internet. And it doesn't work at all. The stupid messages will continue to come back after a reboot(The option will stay off regardless).
I even found the regkey for it, but again, it doesn't matter, it always comes back after a reboot(The key doesn't revert).

This always happens when I play Star Citizen. Upping the page file and more RAM did nothing for me(So I returned the RAM as it really had no performance benefit that I saw in anything). The disabling Aero thing on the shortcut is probably the only way
 

Skripka

[H]F Junkie
Joined
Feb 5, 2012
Messages
10,792
Disabling Aero on the game is the only way in W7.

Seriously.

Nothing else IMHO sticks. Ticking that box off, it'll come back. Telling that box to not bother you again-it will come back. And that brings us having to manually re-enable Aero every fragging time you game because of the nannyism of that stupid warning. And this is on a system with 32GB of RAM and a hefty paging file.

I've never seen the error in W10.
 

ncjoe

Limp Gawd
Joined
Feb 16, 2016
Messages
224
I gotten this message playing witcher 3 ....... everything on ultra, no hair works.......
I tell it to ignore , but still pops up warning when I close the game...

Only way I can get it to not pop up is run a basic theme , out of windows 7 with aero off...

So I have several themes saved now, when I run a game use the basic one, and when I'm
not playing game- use custom theme with aero on......
 
Top