Slow Internet - Fedora Core 8

Mandane

Limp Gawd
Joined
Nov 12, 2003
Messages
164
I apologize, but I could only find one other thread regarding this and it was dead with no useful information.

Okay, for the most part, it would seem that I'm having certain internet connection issues with my new Fedora Core 8 installation. It would seem that the primary issue is that the OS is having difficulties in looking up the appropriate DNS information in a timely manner.

When I try to lookup a website in Firefox, it'll spend 5-6 seconds on "Looking up hardforum.com" as an example. However, once the proper information is obtained, everything loads as it should in a fairly quick manner.

I've alread looked up all the necessary information on disabling IPV6 on Fedora Core, including editing the sysconfig and modprobe files, as well as ending and turning off the ip6tables service.

I've even disabled ipv6 in Firefox, and all of this to no avail.

Also, if it helps, the Yum update is extremely slow. I found that yum-updatesd was tying everything up, and that's because the downloads were going at roughly 4KB/sec. Yeah, try updating a fresh install with those speeds.

So, has anyone have any other possible suggestions on what might be causing all of this? I don't want to try another Linux Distribution for the fact that Fedora Core was the only one that worked out of Gentoo, SuSE and Ubuntu.

Thanks a lot for any helpful information.

Edit

Oh, and I'm running a 3Mb connection, so slow speeds isn't cause by that.
 

alan2308

[H]ard|DCer of the Month - October 2008
Joined
Dec 13, 2005
Messages
4,108
A little more information on your setup would help here. First, what network adaptor are you using? Are you using 32bit or 64bit? As you suspect that its a DNS lookup issue, have you tried entering an IP address in your browser rather than the hostname?

 

Mandane

Limp Gawd
Joined
Nov 12, 2003
Messages
164
Sorry about that. I'm quite ignorant to this.

Network Adapter: Realtek 8111B
OS: Fedora Core 8 64-bit

I'm not quite certain what you're asking for the last part, but after I've looked up the websites IP address, and then use that in the address bar, everything loads instantly instead of the browser looking up the website for a few seconds.
 

Mak

Limp Gawd
Joined
Oct 14, 2005
Messages
150
I had this problem on Linux a couple years ago. I ended up having to put my ISP's DNS server in the /etc/resolv.conf file instead of the IP of the router I was using. That sped things up quite a bit.
 

Mandane

Limp Gawd
Joined
Nov 12, 2003
Messages
164
whats your /etc/resolv.conf and 'netstat -rn' outputs look like?

/etc/resolv.conf:

; generated by /sbin/dhclient-script
nameserver 24.116.2.50
nameserver 24.116.2.34


netstat -rn

Code:
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
96.18.48.0      0.0.0.0         255.255.248.0   U         0 0          0 eth0
0.0.0.0         96.18.48.1      0.0.0.0         UG        0 0          0 eth0
 

Bones

[H]ard|Gawd
Joined
Mar 11, 2000
Messages
1,220
You may as well post your /etc/nsswitch.conf, and also the output of dig to some common website like google (you might need to install the bind tools package to get dig). That will give us a more complete picture of what your DNS situation is.
 

Mandane

Limp Gawd
Joined
Nov 12, 2003
Messages
164
Dig:

Code:
; <<>> DiG 9.5.0a6 <<>> google.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 26286
;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 4, ADDITIONAL: 4

;; QUESTION SECTION:
;google.com.                    IN      A

;; ANSWER SECTION:
google.com.             61      IN      A       72.14.207.99
google.com.             61      IN      A       64.233.167.99
google.com.             61      IN      A       64.233.187.99

;; AUTHORITY SECTION:
google.com.             5776    IN      NS      ns1.google.com.
google.com.             5776    IN      NS      ns2.google.com.
google.com.             5776    IN      NS      ns3.google.com.
google.com.             5776    IN      NS      ns4.google.com.

;; ADDITIONAL SECTION:
ns1.google.com.         184381  IN      A       216.239.32.10
ns2.google.com.         184381  IN      A       216.239.34.10
ns3.google.com.         180940  IN      A       216.239.36.10
ns4.google.com.         181527  IN      A       216.239.38.10

;; Query time: 56 msec
;; SERVER: 24.116.2.34#53(24.116.2.34)
;; WHEN: Tue Mar 18 17:59:50 2008
;; MSG SIZE  rcvd: 212


/etc/nsswitch.conf

Code:
#
# /etc/nsswitch.conf
#
# An example Name Service Switch config file. This file should be
# sorted with the most-used services at the beginning.
#
# The entry '[NOTFOUND=return]' means that the search for an
# entry should stop if the search in the previous entry turned
# up nothing. Note that if the search failed due to some other reason
# (like no NIS server responding) then the search continues with the
# next entry.
#
# Legal entries are:
#
#	nisplus or nis+		Use NIS+ (NIS version 3)
#	nis or yp		Use NIS (NIS version 2), also called YP
#	dns			Use DNS (Domain Name Service)
#	files			Use the local files
#	db			Use the local database (.db) files
#	compat			Use NIS on compat mode
#	hesiod			Use Hesiod for user lookups
#	[NOTFOUND=return]	Stop searching if not found so far
#

# To use db, put the "db" in front of "files" for entries you want to be
# looked up first in the databases
#
# Example:
#passwd:    db files nisplus nis
#shadow:    db files nisplus nis
#group:     db files nisplus nis

passwd:     files
shadow:     files
group:      files

#hosts:     db files nisplus nis dns
hosts:      files dns

# Example - obey only what nisplus tells us...
#services:   nisplus [NOTFOUND=return] files
#networks:   nisplus [NOTFOUND=return] files
#protocols:  nisplus [NOTFOUND=return] files
#rpc:        nisplus [NOTFOUND=return] files
#ethers:     nisplus [NOTFOUND=return] files
#netmasks:   nisplus [NOTFOUND=return] files     

bootparams: nisplus [NOTFOUND=return] files

ethers:     files
netmasks:   files
networks:   files
protocols:  files
rpc:        files
services:   files

netgroup:   nisplus

publickey:  nisplus

automount:  files nisplus
aliases:    files nisplus

Hope this helps... I'm pretty ignorant to these types of issue.
 

Bones

[H]ard|Gawd
Joined
Mar 11, 2000
Messages
1,220
Looks like you're hitting the secondary nameserver - is the primary down for some reason?. The resolver library tries the primary name server first, and waits for an answer for a few seconds before using the secondary, so it's not surprising that you're seeing a delay. Try switching the order of your nameservers in /etc/resolv.conf. That should fix the delay, at least until your dhclient daemon gets restarted.
 
Top