Silverstone ML02-MXR - can’t turn new build pc on

Discussion in 'Home Theater PCs & Equipment' started by MEY, Dec 18, 2019.

  1. MEY

    MEY n00b

    Messages:
    4
    Joined:
    Dec 18, 2019
    I have recently bought the old HTPC case Silverstone ML02-MXR for my first pc build.


    Problem description

    When I plug the power cable into the case and turn the power on on the wall, the iMon display turns on and light and also the diodes on the keyboard light for some seconds and the optical mouse light continuously (they are both connected by PS2), but nothing else happens. There seems to be no display signal to my apple display (which I have tested works) and I can’t hear the HHD spin and the fans also doesn’t turn on. And if I try to press the power button or holding it down for 10 seconds afterwards nothing more happens.


    Correctly cable connections... ?

    I wonder if I have connected the cables to and from the iMon display hardware card correctly...

    I have connected:

    1) The black, red and purple triple wire on the iMon hardware card with the black, red and purple triple wire from the 20 + 4 ATX power connector.

    2) The red and black duo wire on the iMon hardware card with the power button connector (PWRBTN#) at the System header on the motherboard.

    3) The blue and white wire from the power button on the case to the duo connector on the iMon hardware card with the blue wire beneath the white wire.

    Should I instead have placed the white wire beneath the blue one, or doesn’t it matter ?

    In case I have connected the cables wrongly, I would like to know how others who have worked with the Silverstone ML02-MXR have connected the iMon hardware card and the power button on the case of the SilverStone ML02 ?

    In case you think it’s easier, you may also insert some pictures of how you connected the iMon hardware card and the power button on the case of the SilverStone ML02.


    Hardware specifications - for now

    Case: Silverstone ML02-MXR (followed with one case fan)
    PSU: 120 W (followed with the case)
    Case display: iMon LCD display

    Motherboard: Asrock X570m Pro4
    CPU: AM4 Ryzen 3 3200G
    CPU cooler: Noctua NH-L9
    Ram: 32 GB (2 * 16 GB) G.Skill 32GTZNC
    HHD: Western Digital WD30EZRZ / 3 TB
    Optical drive: Pioneer BDR-209EBK used as external drive with IcyBox USB 3.0 and own power supply
    Keyboard: Labtec Media keyboard, PS/2
    Mouse: OPTICAL SCROLL MOUSE 2-BUTTON | PS/2 F/HP PC (QY775AA)
    PS/2 connector: 6IN IBM PS/2 KEYBOARD/MOUSE Y CABLE (KYC1MF)

    Screen: Apple Cinema display (A1081)
    DisplayPort to DVI adapter: Akyga DVI-I - DisplayPort M-F Adapter 0.2m
     
  2. MEY

    MEY n00b

    Messages:
    4
    Joined:
    Dec 18, 2019
    I have changed the white and blue wire, and afterwards I could turn the pc on without any problem. smiley1.gif smiley36.gif
     
    Dark12 likes this.