Should a 9600 se be able to play C&C Generals?

Robteam70

Account Locked by Admin
Joined
Dec 31, 2005
Messages
8
This game runs real crappy on our comp and I'm trying to get it to run better for my Dad. We have p4 3.0ghz proc, 512 mb ram, and a radeon 9600 se. I'm using catalyst 5.11 drivers. The chassis is a gateway micro tower so we are limited to low-profile graphics cards unless we transplant the guts into a full-sized tower, if that is even possible.

The computer came with a 180 watt power supply and most people told me that this would not be enough for my card. I have since bought an antec 400-watt unit to see if that was the problem and it made no difference.

The min. video card requirements for this game are only a geforce 2 or radeon 7500. So I guess my question is if this card should be able to run that game ok on low-quality settings, or if the bottleneck is somewhere else. Any suggestions?
 

PWMK2

2[H]4U
Joined
Dec 4, 2005
Messages
3,032
Yes, yes, yes. The 9600SE should own C&C generals. You should probably be able to play with max settings. I played it on my mom's computer which had a Geforce 4 MX 440 (which is way worse than the 9600SE) with 512MB of RAM and a 2.6 GHz Northwood (without HT) and it played with max settings @ 1024x768.

I don't see any bottleneck myself. What kind of settings have you set the game at?
 

Occidio

[H]ard|Gawd
Joined
Dec 17, 2005
Messages
1,497
Shouldnt be a problem at all. I use a Panasonic CF-50 at work and it has a 7100 notebook video card in it and it runs Generals fine. Is the computer still running the OS that came from Gateway. There could be a crap load of extra stuff running in the background.
 

Demicore

n00b
Joined
Jul 13, 2005
Messages
33
My friend has a P4 3.0ghz with a 9550 and 512mb ram and plays it perfectly. Same for me with my t-bred 2400+, 9600 pro and 512mb ram. You should have no problem :) (but if you want to play online you should definitely purchase Zero Hour, not much people playing vanilla gens these days...)
 

Robteam70

Account Locked by Admin
Joined
Dec 31, 2005
Messages
8
Thanks for the replys guys. I've been trying it on low settings, and 800x600 resolution! 1 v 1 battles don't play too bad, but when you start adding 4-6 on the same map the game gets totally unplayable.

It is running Windows XP, the OS that came with Gateway. I'm sure it does have plenty of stuff running in the backround that I can't find. There aren't any applications running under task manager though, and cpu usage is only about 1 percent at idle, PF usage is about 240 mb.

It actually is zero hour that I'm referring to. I haven't tried to play it online much except with my cousin, and we had constant problems with lockups. I've just figured this comp wouldn't handle online play since it can barely handle the game offline. I'm sure this game is a blast online though, I used to be crazily addicted to playing starcraft on Bnet.
 
Top