Shadow Warrior runs like garbage on my PC?

piscian18

[H]F Junkie
Joined
Jul 26, 2005
Messages
11,021
Seeing a kind of bizarre issue with Shadow Warrior and I'm kind of curious if anyone has seen something similar.

It's stuttering insanely bad, ingame and in menu's. Even weirder after I close it my PC stutters for a couple minutes then finally calms down. I even turned it down in medium settings and 1920x1080.

Weirder still when I launch it in "xp mode" which is one of the options when you launch it from steam. With that it runs great.

I started to troubleshoot my PC but DOOM(2016) runs perfectly and I just finished Sleeping Dogs last night that runs great.

Anybody see weirdness like that before?
 

Blade-Runner

2[H]4U
Joined
Feb 25, 2013
Messages
3,553
Nope, consistently smooth when I played it. Seems strange given that the devs put out several optimising updates. What are your hardware specs?
 

Draax

Supreme [H]ardness
Joined
Aug 11, 2005
Messages
5,213
I had the same issue after installing updated nvidia drivers. The game was smooth prior but after the install it was a slideshow. Even the opening movie (the dragon going over the sword) was choppy. I used DDU (display driver uninstaller) to wipe the drivers and then reinstalled then. That fixed my problem.
 

SixFootDuo

Supreme [H]ardness
Joined
Oct 5, 2004
Messages
5,775
You guys have to go into the Nvidia drivers and actually turn the performance back on. I do not know why Nvidia does this. No, I am not kidding. There are guides out there. Under managed 3d settings, most of the first 4 or 5 items need to be turned off. Under power management I think, that needs to be turned to "max peformance" ... display to 1, a few other odds and ends need to be changed from the default settings to boost performance.
 

Mortuus

[H]ard|Gawd
Joined
Sep 2, 2007
Messages
1,279
You guys have to go into the Nvidia drivers and actually turn the performance back on. I do not know why Nvidia does this. No, I am not kidding. There are guides out there. Under managed 3d settings, most of the first 4 or 5 items need to be turned off. Under power management I think, that needs to be turned to "max peformance" ... display to 1, a few other odds and ends need to be changed from the default settings to boost performance.

well thats stupid lmao
 

FrgMstr

Just Plain Mean
Staff member
Joined
May 18, 1997
Messages
52,040
You guys have to go into the Nvidia drivers and actually turn the performance back on. I do not know why Nvidia does this. No, I am not kidding. There are guides out there. Under managed 3d settings, most of the first 4 or 5 items need to be turned off. Under power management I think, that needs to be turned to "max peformance" ... display to 1, a few other odds and ends need to be changed from the default settings to boost performance.
I would like to see some more of the specifics you are talking about exactly. I think you may be confused.
 

piscian18

[H]F Junkie
Joined
Jul 26, 2005
Messages
11,021
I had the same issue after installing updated nvidia drivers. The game was smooth prior but after the install it was a slideshow. Even the opening movie (the dragon going over the sword) was choppy. I used DDU (display driver uninstaller) to wipe the drivers and then reinstalled then. That fixed my problem.


Geez I havent had to wipe drivers in ages I'll give that a shot thanks.
 

piscian18

[H]F Junkie
Joined
Jul 26, 2005
Messages
11,021
I had the same issue after installing updated nvidia drivers. The game was smooth prior but after the install it was a slideshow. Even the opening movie (the dragon going over the sword) was choppy. I used DDU (display driver uninstaller) to wipe the drivers and then reinstalled then. That fixed my problem.


Thanks that was it, hide to wipe and clean out drivers, its buttery smooth now.
 
Top