Saving new Office 2010 documents very slow.

Discussion in 'Networking & Security' started by scottatwittenberg, Jul 13, 2012.

  1. scottatwittenberg

    scottatwittenberg 2[H]4U

    Messages:
    3,307
    Joined:
    Apr 10, 2002
    This only happens on 2 computers, the rest are all fine.

    When a user creates a new Microsoft Office document and save it, it takes 30+ seconds to save.
    Once the file is created, they can open and edit it and save with no issues, it is just when a new document is created and saved.

    The 2 computers it is happening on are Windows 7 pro. The server is 2008 R2. It is a small domain with 10-15 computers. Everything is less than a year old, cabling, switches, sever, computers.
    One computer that has this problem was ghosted from the same image as 5 other laptops and none of them have the same issue.
    They are running Microsoft Security Essentials.

    Anyone see this before?
     
  2. gimp

    gimp Zed Rapes Me

    Messages:
    10,038
    Joined:
    Jul 25, 2008
    when does the issue occur?
    when saving directly to the server?
    saving to the local both?
    both?
     
  3. scottatwittenberg

    scottatwittenberg 2[H]4U

    Messages:
    3,307
    Joined:
    Apr 10, 2002
    I am pretty sure both.

    The one computer has all of the user folders pointed to the server with offline files turned off.
    //server/users/username/documents etc.

    The other user has offline files turned on, and the same setup with user folders pointed to the server.
     
  4. gimp

    gimp Zed Rapes Me

    Messages:
    10,038
    Joined:
    Jul 25, 2008
    try this:
    http://support.microsoft.com/kb/2292752

    although that's only if the issue only occurs when saving to a mapped drive/network location
    hence the question is theh issue occurs when both saving locally and to a network drive
     
  5. k1pp3r

    k1pp3r [H]ardness Supreme

    Messages:
    7,810
    Joined:
    Jun 16, 2004
    I had this issue on a clients PC. Spent about 4 hours on the phone with Microsoft and they could never get a solution to it.
     
  6. TechLarry

    TechLarry Pick your own.....you deserve it.

    Messages:
    28,838
    Joined:
    Aug 9, 2005
    One thing to always check with Office performance issues it to make sure the default printer is not set to a dead or missing printer.
     
  7. Mister Natural

    Mister Natural 2[H]4U

    Messages:
    3,549
    Joined:
    Oct 10, 2002
    Yep and printers that have memory slots that assign drive letters can cause office sluggishness.
     
  8. scottatwittenberg

    scottatwittenberg 2[H]4U

    Messages:
    3,307
    Joined:
    Apr 10, 2002
    Sorry it has been so long..

    I am testing it now.

    It is not a profile issue. I logged in as another user, it created a new profile, I mapped a drive and saved to it. It is extremely slow..

    It saves normally to the local hard drive.

    I tried the patch above, and it said it didn't apply to my system.
     
  9. cyclone3d

    cyclone3d [H]ardForum Junkie

    Messages:
    12,299
    Joined:
    Aug 16, 2004
    run an administrative command prompt and enter:

    netsh int ip reset C:\reset.log

    Reboot when it tells you it is done and see if that fixes it.

    You can also look at the log and see what it says.

    Have you tried plugging the computer into a different LAN port.. may need to move to a different room.

    Here is another huge thing that I just remembered will cause this every time. And it can also cause lots of programs to say that it can't open the file because it is already in use.

    It is the awefullness of Windows explorer "preview mode".

    If that is on, turn it off. Open up explorer(My computer), browse a drive, look for the little box up in the right hand corner near the question mark icon. Hover over it, I bet it will pop-up "Hide the preview pane" click it to disable the preview pane.

    This should cure about 100% of slow file access and saving issues and errors.
     
  10. scottatwittenberg

    scottatwittenberg 2[H]4U

    Messages:
    3,307
    Joined:
    Apr 10, 2002
    Netsh command did not work. and it didn't create a log

    Preview pane is not shown.

    I tried disabling auto-tuning using netsh as well.

    I turned off ipV6

    I removed "remote differential compression"

    I think I really need to try the port next.
     
  11. MrGuvernment

    MrGuvernment Pick your own.....you deserve it.

    Messages:
    19,751
    Joined:
    Aug 3, 2004
    disconnect all networks drives / shares ?
     
  12. sirianthe3rd

    sirianthe3rd n00bie

    Messages:
    1
    Joined:
    Aug 15, 2012
    This is going to seem really dumb and simple, but I had a similar issue a few months ago where any Office 2010 document I tried to save or open on a network share would have a horrible delay, anywhere from 30 seconds to 10 minutes. The 10 minute delay was OneNote documents, specifically.

    It was resolved by simply unchecking the "automatically detect settings" box under Internet Options -> Connections tab -> LAN Settings. Then reboot. Instantly fixed.

    Tried every other fix that I could Google, from netsh tweaks to firewall settings to AV tweaks to everything else.
     
  13. scottatwittenberg

    scottatwittenberg 2[H]4U

    Messages:
    3,307
    Joined:
    Apr 10, 2002
    I tried this and it seemed to help I would say it brought it from 30 seconds down to about 5:

    You will need to disable SMB2 on the server that holds the share. To do so:

    Add a REG_DWORD entry named Smb2 with a value of 0 to
    HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters
     
  14. eagle23

    eagle23 [H]Lite

    Messages:
    121
    Joined:
    Mar 9, 2001
    another thing that happens with office is recently opened files history. If a networked share file is in that list it looks for it everytime you are in the open or save prompts. Lower the number of recently opened files to 0 and see the difference.