Route Redistribution between EIGRP/BGP on Cisco ISR4321

/dev/null

[H]F Junkie
Joined
Mar 31, 2001
Messages
15,182
Stuck on an issue where on an ISR4321 I'm redistributing routes from EIGRP into BGP & they aren't showing up.

Anyone done this before? I think I may be missing something.

If I shut the interface with the BGP connection, the route shows up in the routing table...just not sure why it's not getting installed when both interfaces are up (one running bgp, the other running eigrp) andI have a route-map that tags eigrp redistributed routes with weight 250 when my main bgp connection is only weight 200.
 
What do you mean by "they aren't showing up"? Are you getting errors, or is show bgp just not giving you the info?
 
Can you post the eigrp and bgp config sections?

When I am in the office tomorrow I'll post them.

What do you mean by "they aren't showing up"? Are you getting errors, or is show bgp just not giving you the info?

No errors, just the route isn't showing up in the routing table (no VRFs in use).

Strangely enough if EIGRP interface comes up first, the EIGRP route gets installed, and after BGP interface comes up, it stays installed. If Eigrp interface goes down, it switches to BGP (weight 200) and when EIGRP comes back up (where the route is supposed to be tagged as weight 250 when it is redistributed) router still prefers the routed received from the BGP peer.

It has to be something simple I'm missing.

Also: Code is 16.9.3
 
SC14 is the router I'm trying to fix my configuration on. The route in question is 10.4.2.0/24.

Normally it should come via EIGRP, as the EIGRP is a 4948 switch (only running eigrp) with a 1Gbit link to another switch that actually has that as a connected interface.
If that link fails, that route should come in over the BGP interface (backup 50Mbit circuit)

Code:
SC14# sh run int Gi0/0/0
Building configuration...

Current configuration : 124 bytes
!
interface GigabitEthernet0/0/0
 desc EIGRP Interface
 ip address 10.150.3.3 255.255.255.248
 negotiation auto
end

SC14# sh run int Gi0/0/1.141
Building configuration...

Current configuration : 134 bytes
!
interface GigabitEthernet0/0/1.141
 desc BGP Interface
 encapsulation dot1q 141
 ip address 100.65.0.22 255.255.255.252
end

SC14# sh run | b ^router eigrp 150
router eigrp 150
 maximum-paths 1
 network 10.150.3.0 0.0.0.7
 redistribute bgp 64544 metric 50000 50 255 1 1500 route-map bgp-to-eigrp
 distance eigrp 90 90
 passive-interface default
 no passive-interface GigabitEthernet0/0/0
!

SC14# sh run | b ^route-map bgp-to-eigrp
route-map bgp-to-eigrp deny 10
 description ROUTE REDISTRIBUTION LOOP PREVENTION
 match community comfilter3120
!
route-map bgp-to-eigrp permit 20
 set tag 3120
!

SC14# sh ip community-list comfilter3120
Named Community standard list comfilter3120
    permit 0:3120

SC14# sh run | b ^router bgp 64544
router bgp 64544
 bgp log neighbor-changes
 network 100.65.0.20 mask 255.255.255.252
 redistribute eigrp route-map eigrp-to-bgp
 neighbor 100.65.0.21 remote-as 3549
 neighbor 100.65.0.21 next-hop-self
 neighbor 100.65.0.21 allowas-in 2
 neighbor 100.65.0.21 soft-reconfiguration inbound
 neighbor 100.65.0.21 weight 200
 neighbor 100.65.0.21 route-map from-as3549 in
 neighbor 100.65.0.21 route-map to-as3549 out
!

SC14# sh run | b ^route-map eigrp-to-bgp
route-map eigrp-to-bgp deny 10
 description ROUTE REDISTRIBUTION LOOP PREVENTION
 match tag 3120
!
route-map eigrp-to-bgp permit 20
 match ip address prefix-list pl-1
 set weight 250
 set community 0:3120
!
route-map eigrp-to-bgp permit 30
 set weight 10
 set community 0:3120
!

SC14# sh run | i pl-1
ip prefix-list pl-1 seq 5 permit 10.4.0.0/16 ge 24 le 29

This has been edited to remove sensitive information.
 
I think this may be what I'm runng into:

Second, when you had the link to R3 down , you lost the EIGRP prefix from the topology table and when reenabling that link it comes back up in the topology table but won't make it into the routing table and so can't be redistributed into BGP table.

It isn't installed in the routing table because you already have this prefix installed with an AD of 20 which beats the AD of 90 of EIGRP but when you clear the BGP neighborship with R2 then this prefix is withdrawn from the routing table and the BGP table, the EIGRP prefix is installed in the routing table then redistributed into BGP and as soon as the BGP neighborship is up again then the BGP table learns about the prefix from the eBGP neighbor again and they are both in the BGP table.

But on R1 it should be installed as an EIGRP route with an AD of 90.

Apparently EIGRP routes are only redistributed into BGP only if they make it into the main routing table first.... I think my n00bness is showing here :-/ I thought they'd get re-distributed (and processed by route-map) & then compared, but that doesn't seem to be the way it works.

When BGP is up & EIGRP is down, BGP installed 10.4.2.0/24 to routing table (with AD 20)
When Eigrp then comes up, nothing gets installed due to AD 90.

When EIGRP is up & BGP is down, 10.4.2.0/24 via EIGRP peer makes it into routing table, then gets redistributed with route map into bgp with weight 250. Then when BGP comes up, it learned 10.4.2.0/24 from peer with weight of 200 so it works.

I think what i probably need to do is in the EIGRP config something like

distance 19 <eigrp peer address> 0.0.0.0 <standardacl that contains 10.4.2.0>

Sadly the standard acl can't match the flexibility of the prefix-list, and it doesn't appear i can use a prefix-list or route-map (better) with a distance command, so I think I'm going to have to make a standard acl close to my prefix list that will work for my purpose.
 
Last edited:
And...this solution works for eigrp "internal" routes but not external. AD isn't changed for those...*bangs head on desk*.
 
I seem to recall AD not mattering on eigrp routes redistributed in to BGP, like they default to 32768 or something like that. It's been a while.......sorry
 
I seem to recall AD not mattering on eigrp routes redistributed in to BGP, like they default to 32768 or something like that. It's been a while.......sorry
I think all ADs are 90(internal)/170(external)on EIGRP, and I dont' think BGP cares what the AD is on them...
 
Back
Top