Quick question: is this normal?

Rhialto

Gawd
Joined
Feb 23, 2004
Messages
545
Just got a Corsair HX520W and computer case but the motherboard will come in tomorrow.

So meanwhile I decided to start installing it and wanted to test the fans (from case, not PS) so I plugged the fans and turned power on but nothing. Is it because there is no load or there is no motherboard that the PS won't power the fans alone? The fan from the PS do not spin and I know this is normal.

I just hope it's not DOA.
 

Desdichado

Limp Gawd
Joined
Apr 22, 2006
Messages
331
That's normal. The psu has to get a power on signal from the motherboard to turn on, so it won't power anything unless you have it plugged into a motherboard.
 

longblock454

2[H]4U
Joined
Nov 28, 2004
Messages
2,271
Usually the power will kick on for a very short time, like less than a 1/2 second before it shuts off. But probably normal.

How did you turn it on? If its not connected to the MB you have to ground the Green wire on the ATX connector, otherwise it won't even try to power up.
 

Rhialto

Gawd
Joined
Feb 23, 2004
Messages
545
How did you turn it on? If its not connected to the MB you have to ground the Green wire on the ATX connector, otherwise it won't even try to power up.

I'd like to try this but I'm not sure how to exactly and don't want to blow it up.
 

Teknokid

[H]ard|Gawd
Joined
Feb 17, 2007
Messages
1,292
psu wont work unless its powered on by mobo or shorted with green wire... nothing wrong with psu.
 

Rabid Badger

2[H]4U
Joined
Mar 9, 2006
Messages
2,093
Ok guys, how hard is it to type this sentence:

What you need to do is take a paper clip and use it to connect the green wire to any black wire on the main ATX motherboard plug, then flip the switch. The PSU should power on.
 

Tim James

Limp Gawd
Joined
Feb 27, 2007
Messages
313
Yeah that's normal. Just use a paperclip between the green wire and a black wire on the motherboard connector.

I wonder if he's got it now? :rolleyes: ;)
 
Top