Problems related to an old server


Sep 10, 2002
Hey, I recently aquired an extremely old server from my school for fixing a new one. My problem however is that I can't access the BIOS.

My teacher claims the BIOS is on a CD. I have that CD, but there is nothing on it that can be run through DOS, so I think he's an idiot..... The server is an HP NetServer LH Pro. It's running PhoenixBIOS Version 4.05.16.

The system has 5 drives on RAID, they are each 4gb drives. I have tried using a Win2k Serv boot disk, and loading into NTLDR, then putting in a Win2k Server CD and running through the install. In the menu, the drives are all listed wrong. It comes up with one 2gb, one 18gb, and two 4gb. That doesn't make any sence, concidering there are 5 drives and they are each 4gb in size.

I have also tried booting off a Win2k Server CD, and it gives me an error "NTLDR not found". If anyone has any information that can help, please let me know. I am currently looking for a BIOS revision, perhaps that will help me figure this thing out.
I'd flash the BIOS then install your OS of choice then get the latest BIOS revision and install it.

Or go to another computer and get the lastest BIOS revision for the board and install it then try to install the OS and see if it recognizes the drives correctly.
maybe its just me, but i've never heard of a comptuer's bios being stored on a cd. so i say your teacher doesn't know wtf he's talkin about.

as with trying to boot off the server cd, depending on how old the computer is, it might not be able to boot off cd. so your best bet is to just use a floppy boot disc.
We flashed the BIOS and got that set up. We're still having problems trying to get the HDD's reading and working properly. The server is at our school right now, so we'll try some stuff tomorrow and hopefully report back with more info.

Thanks for the help so far guys.
Yeah, after the BIOS flash, I found some software on the HP webpage that is used to configure the BIOS settings.

It seems this BIOS doesn't have a built in menu of any kind, and it must be loaded off the disk.
LOL. I was expecting Mike's terribly typing, then I read it and realized you're logged in as him.

Yeah, I tried to log out about 15 times. For some reason it wouldn't clear the cookie. So I just posted anyway.

But now it's ok.
you need to boot from a HP Navigator CD. it will detect your hardware and bios/firmware updates are on there. you can also manage your hp raid controller from the gui util from there.
Ok, now my main problem is getting the system to have a bootable drive. The main issue is that the SCSI card got shocked by some dumb kid in my class.

At one point in time I managed to get it to boot from CD, but it wasn't the correct CD. From that point on I haven't been able to do it. I guess I'll just have to keep trying.

Also, do you know I need that SCSI card for the system to work correctly? I know inside the case on the chassis there is a diagram that shows two different set up methods, one with the external SCSI, and one without. I have the system set up how that diagram says it should be if I don't have a SCSI card.

I'll get back to you on my results. And thanks for the help so far.
Some of the older SCSI stuff can have problems putting the bootstrap onto an NTFS partition- a work around that i've used on a Compaq Smart Array controller when time was a pinch (5 drive array), was to do an 8gb windows partition in FAT, then the remainder of the space in NTFS.....
Ok, well I'm making progress! lol.
I finally found my HP Navigator CD.... My teach gave me the wrong disk. Turns out the real navigator CD was in a paper cd envelope glued to the bottom of an anti-static bag full of diskettes.

Anyway, I managed to get into the Navigator program, and I ran through all the settings. However, when came time to do the hard drive array, it told me I had no array support set up. Later on I found out the computer is only picking up 2 drives. Although at bootup it lists all 5 as successful detections on the SCSI controllers.

I'm starting to think I need that SCSI card to get this system to work. So, when I get to school today, I'm taking it home with me. Perhaps it does work, now that I have figured this thing out for the most part, it could actually not have been the SCSI card all along. For the record, I checked out a few sites that are concidered official HP server repair stations. Apparently I can pick up my suposed broken part for the low price of 1,200$US! Yeah right! I don't have 1,600$ to dish out on a SCSI controller....

Anyway, back to my new problem. The only way I could get on the Navigator CD was to through in the original drive. However, it isn't actually the original HP drive. Someone replaced it with a SCSI NEC 3x Case drive. You know those really old ones that you put the CD in a cartredge that has a slider like a floppy disk? Well for those of you that know what I'm talking about, great, for the rest, just call me insane.

So I get into the Navigator, I go through all the options, set up the system and shutdown. I through in my OS CD (Server2003) and start it. It goes through all the load up stuff, and then tells me that it can't find NTLDR again, like before.

Now I'm starting to think that is because the drive is 3x and can't read the CD as fast as it needs too. Or maybe it's by burn. I'm thinking of reburning it at 1x, instead of 48x. My brother said that should work. Now because a 1x burn takes like 3 days (lol) I'm going to let it run while I'm in school. While there I'm also going to grab a few other OS disks, like NT Server. Apparently the Navigator has NT install junk built into it, so that may help me out. I could then upgrade the OS after I get into NT.

So yeah, after that story.... Does anyone know if it is possible to set the system up to boot off of an IDE CDROM, instead of a SCSI like it does now?? I have probably 15 IDE CDROMs around the house, but not a single SCSI. If speed is the issue, it looks like I'm going to have to buy a fast SCSI CDROM.